Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Version issues in implementing eCommerce solution using AEM 6.0 and Hybris 5.1.1

Avatar

Level 2

Hi Guys,

We are on verge of starting new eCommerce project and we have decided to integrate AEM and Hybris.

Based on release notes http://docs.adobe.com/content/docs/en/aem/6-0/release-notes.html in commerce section it is mentioned that :

      
Hybris 5.1.1 supportSupport for the latest hybris version (per May 2014).Enhancement

But on eCommerce wiki page for AEM 6.0 at http://docs.adobe.com/docs/en/aem/6-0/develop/ecommerce/hybris.html it is mentioned that :

CAUTION : "hybris is currently not working with AEM 6.0, only with AEM 5.6.1"

So we are confused regarding which version of AEM and Hybris to user for this new implementation.

Also we have previously tried using AEM 5.6.1 and Hybris 5.0.4 using package cq-hybris-content-5.6.2 and it didn't work

Can some one please clarify our below queries :

1) Shall we use AEM 6.0 for eCommerce implementation on top of Hybris ?

2) If yes, Which version of Hybris is supported with AEM 6.0, is Hybris 5.1.1 supported or we should use other older version?

3) Which version of cq-hybris-content package should be used ?

Appreciate your help !

 Thanks,

Faizaan Shaikh

1 Accepted Solution

Avatar

Correct answer by
Employee

Hi Faizaan,

If you want to use AEM 5.6.1, you have to request the eCommerce packages 5.6.200 (not 5.6.2) via your Daycare account. 5.6.2 is not working with AEM 5.6.1 that's why you had all the issues.

If you want to use AEM 6.0, you need to wait until we have released the packages. Still you would need to request access via Daycare.

 

Regards,
Martin

View solution in original post

11 Replies

Avatar

Employee

Hello,

According to the latest information that we have for the 6.0 packages:

"The packages are still not ready. They are currently being tested.

There is no official date, but they should be available soon."

(see the thread at: http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...)

The technical requirements for integrating hybris with AEM 5.6.1 are covered at:

http://docs.adobe.com/docs/en/cq/current/ecommerce/eCommerce-hybris.html#Technical%20Requirements%20...

which includes the note: "hybris 5.1 is currently not supported."

Avatar

Employee

Hi Faizaan,

Just before we wanted to release the hybris package for AEM 6.0, hybris 5.2 came out. We decided to include the 5.2 compatibility and not to release the packages before.

The AEM 6.0 hybris packages will come out by the end of this week, you will find them on package-share.

Avatar

Level 2

Hi Martin,

Thanks a lot for confirmation, appreciate your help !

As we are starting new project we would like to know best stable version combination of AEM/CQ and Connector package to avoid issues later.

Is it recommended to use AEM-6 for eCommerce implementation on top of Hybris 5.1.1 (or other Hybris version), or shall we use AEM 5.6.1 with Hybris 5.0.4.

If possible can you please let us know any key issues that have been fixed in latest connector version or valuable enhancements/features that have been added.

Once again appreciate your help !!

Thanks,

Faizaan Shaikh

Avatar

Employee

Hi Faizaan,

I would definitely go with AEM 6 and the latest hybris version 5.2. We always work to improve stability / performance and everything we will do in future will be based on AEM 6.0.

Have you seen our release notes here: http://docs.adobe.com/docs/en/aem/6-0/release-notes.html

Or is there something in particular you're looking for?


Regards,
Martin

Avatar

Level 2

Hi Martin,

Thanks again for your prompt reply !

Since few days we are doing POC using AEM 5.6.1 and Hybris 5.0.4 using Hybris connector version cq-hybris-content-5.6.2.

We are facing below blocker issues using that :

  • Products were not getting imported from Hybris to AEM due to XML feed parsing issues in connector and we are getting below error :  
    06.05.2014 17:31:29.762 *INFO* [127.0.0.1 [1399377642438] POST /libs/commerce/content/import.html HTTP/1.1] com.adobe.cq.commerce.hybris.impl.importer.HybrisImporterImpl Skipping product due to missing base product information    (code/path): null
  • AEM-Hybris session handling :- when adding product to cart it is always adding to anonymous user cart instead of current AEM logged in user cart, there seems to be some issue in BasicAuthHandler implementation, may be using oAuth 2.0  in new version can resolve this issue.
  • During catalog blueprint roll out if product was not having 2 variants 'productData' attribute value was not getting populated in product component on product page.
  • Also if we see pom.xml of hybris-impl project in cq-hybris-content-5.6.2.zip it is dependent on commerce API version cq-commerce-core-5.6.16.jar which is different from OOTB version installed in AEM 5.6.1 i.e cq-commerce-core-5.6.18.jar due to that we got lot of ScriptEvaluationException on JSP pages as there are some interface definition changes eg:- : CommerceService.java and Product.java.
  • If I try to use cq-commerce-core-5.6.18.jar in cq-hybris-content-5.6.2.zip hybris-impl project than com.day.cq.commons.inherit.ComponentInheritanceValueMap does not gets resolved in HybrisServiceImpl.java as it has indirect dependency on com.day.cq.commons.inherit.ComponentInheritanceValueMap

         So can you please let us know, if this all issues will be resolved using AEM 6.0, as it will be having updated Hybris connector, commerce-core and PIM bundles. 

         Appreciate your help !

Thanks,

Faizaan Shaikh

Avatar

Employee

Hi Faizaan,

Just to make sure that you are using the right packages:

- cq-commerce-hybris-update-content-5.6.200
- cq-geometrixx-hybris-content-5.6.200 (for the demo store)

Avatar

Level 2

Hi Martin,

I don't have this packages listed in package share, latest one I can see is 5.6.2 version.

Shall I wait for new packages to be released by end of this week, will they be accessible via package share in public section or will it require separate access ?

Thanks,

Faizaan Shaikh

Avatar

Correct answer by
Employee

Hi Faizaan,

If you want to use AEM 5.6.1, you have to request the eCommerce packages 5.6.200 (not 5.6.2) via your Daycare account. 5.6.2 is not working with AEM 5.6.1 that's why you had all the issues.

If you want to use AEM 6.0, you need to wait until we have released the packages. Still you would need to request access via Daycare.

 

Regards,
Martin

Avatar

Level 2

Hi Martin,

Thanks for your prompt replies !

Requesting a last favor from you if you can please update this forum post when new packages are released for AEM 6.0, so we can raise a Daycare ticket to get it's access.

Appreciate your help !

Regards,

Faizaan Shaikh

Avatar

Employee

Hi Faizaan,

The hybris 6.0 bundles are available now on package-share. You need to request access through Daycare though.

Regards,
Martin

Avatar

Level 2

Thanks Martin !

Requesting access for it through Daycare.

Regards,

Faizaan Shaikh