Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

var clientlibs deleted

Jai1122
Level 5
Level 5

Hi Experts,

  In one of our environments we cleared the clientlibs cache by using "Invalidate Cache" in

http://localhost:4502/libs/granite/ui/content/dumplibs.rebuild.html.

This deleted the var/clientlibs folder. Now clientlibs are not at all loading and the var/clientlibs folder didnt get created again.

Please help us in identifying the issue.

Thanks,

Jai.

1 Accepted Solution
Brumoon_Ahamat
Correct answer by
Level 2
Level 2

Sure, in crx/de click on var/clientlibs, and then "Access control" tab where it show the "properties", and then add Principal "Everyone", and privileges "jcr:all". That was what I did to solve the problem. However, I later found out that principal should be "clientlib-service" with read write privileges. Hope this helps. Please let me know if this works.

View solution in original post

0 Replies
smacdonald2008
Level 10
Level 10

Did you follow all the steps in the AEM docs:  https://docs.adobe.com/docs/en/cq/5-6/deploying/dispatcher/page_invalidate.html

Also - are you getting another messages in the log file? 

Sham_HC
Level 10
Level 10

Invalidating cache will remove everything below /var/clientlibs but not root clientlibs. So surely something else happened. For now create the folder manually & restart the server

Manish_Singh_1
Employee
Employee

Did you try to rebuild the clientlibs from the same url? Which version of AEM are you using? Try creating the va/clientlibs folder yourself from crx/de and try again

Jitendra_S_Toma
Level 9
Level 9

Hi Jai,

Here are things you can could to fix this issue.

  1. Even if you have deleted clientlibs folder, if you deploy your code again, it should be created.
  2. How do you expect to be created? AEM does not create this folder automatically for you.
  3. You can create this folder manually and deploy the code again. 

Jai1122 wrote...

Hi Experts,

  In one of our environments we cleared the clientlibs cache by using "Invalidate Cache" in

http://localhost:4502/libs/granite/ui/content/dumplibs.rebuild.html.

This deleted the var/clientlibs folder. Now clientlibs are not at all loading and the var/clientlibs folder didnt get created again.

Please help us in identifying the issue.

Thanks,

Jai.

 

Brumoon_Ahamat
Level 2
Level 2

Stumbled upon this while troubleshooting similar issue of deleting the /var/clientlibs. Recreating the folder did not work. After adding permissions to everyone jcr:all, it worked. Hope this will help someone else.

jackie_chan_
Level 2
Level 2

Can you explain what you mean by"adding permissions to everyone jcr:all"?

I'm having the same issue and would love to know how you fixed it.

Thanks!

Brumoon_Ahamat
Correct answer by
Level 2
Level 2

Sure, in crx/de click on var/clientlibs, and then "Access control" tab where it show the "properties", and then add Principal "Everyone", and privileges "jcr:all". That was what I did to solve the problem. However, I later found out that principal should be "clientlib-service" with read write privileges. Hope this helps. Please let me know if this works.

View solution in original post

dwalling
Employee
Employee

@brumoona87688495 if you have Communities FP5 or later installed, we've discovered an incompatibility. Please see this suggestion:

http://help-forums.adobe.com/content/adobeforums/en/experience-manager-forum/adobe-experience-manage...

If you do not have a Communities feature pack installed then the problem may be different and that solution may not apply