Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

jackie_chan_
Community profile jackie_chan_ Level 2
Job title here
Location here
9 BADGES
Level 2

Level 2

Learn more
Joined the community 23-05-2017 8:42:52 AM
Offline
Top badges earned by jackie_chan_
Customize the badges you want to showcase on your profile
Re: AEM 6.4: cq:dialog multifield saves attribute with @Delete
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
Thanks again.I've got the new granite/coral multifield working now and it's showing the stored values.However (and this is likely the wrong thread to ask, but figured it's relevant), in a jsp page, is there a way to iterate over the child nodes (i.e. item0, item1, etc) of the multifield node that's created?

Views

1.7K

Likes

0

Replies

0
Re: AEM 6.4: cq:dialog multifield saves attribute with @Delete
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
Thanks smacdonald2008​!This is working however, the saved configuration is not being displayed again when opening up the configuration dialog again, even though the configuration is saved when viewing in CRX. I'm not creating a HTL component, but I'm not sure if that will impact the displaying of the saved config.

Views

1.7K

Likes

0

Replies

0
AEM 6.4: cq:dialog multifield saves attribute with @Delete
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
I'm setting up my cq:dialog to use multifield, which contains either a form select or checkbox field in my component.However, when I set the value when configuring the component, the field is stored with an additional "@Delete" appended to it and I can't access/read this field in my page. Here's my context.xml for the cq dialog: and when I look at CRX for the properties of the configured component, I get the following:Name: featuresType: StringValue: {"optionA@De...

Views

4.2K

Like

1

Replies

7
Re: Old templates (app/project/templates) issue in 6.4; can it be converted?
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
Thanks for your help. I'll try adding back /etc/designs/project for now to see if that helps.I'm aware how to add components into the component browser by going to the design mode. However, I want to have that defined on the template level (much like a policy in the new editable templates) so that the author doesn't have to keep doing that after creating a page with that template. Is there a way to do this in 6.4 anymore for static templates?

Views

695

Likes

0

Replies

0
Old templates (app/project/templates) issue in 6.4; can it be converted?
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
I'm currently on 6.2 but am moving over to 6.4 and trying to re-use my templates that I've created as part of my project (under /apps/project/templates).The challenge I'm having is that all of the parsys and layout containers don't have any default component groups defined.Previously, they were defined in /etc/designs/project, but from what I can tell, that path is no longer used?Is there a way to still use these templates and specify the allowed component groups by default without having the au...

Views

904

Likes

0

Replies

3
Re: minifying JS and CSS in 6.2 causing errors
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
Quick update: Looks like YUI isn't able to handle the angular .catch() functions and as a result, the minification breaks. Without going back and changing all of our code, it doesn't look like we can use the OOTB minification in AEM (unless someone here has some other suggestions/recommendations?).

Views

2.3K

Likes

2

Replies

0
Re: minifying JS and CSS in 6.2 causing errors
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
Thanks everyone for the help! I'll give these a go and update here!Cheers!

Views

2.3K

Like

1

Replies

0
minifying JS and CSS in 6.2 causing errors
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
Hi folks,Hoping someone can help me with this task. As you can see by the title, I'm trying to minify the JS for our site and all of it's associated components in AEM 6.2.We are using angular 1.5.5 across the site and components, and when I go to the AEM Web Console Configuration > Adobe Granite HTML Library Manager and check the Minify option, when we hit the site, I'm seeing issues in my JS console:Could someone point me in the right direction of how to minify the site.js that's generated?Than...

Views

9.7K

Likes

4

Replies

11
Re: var clientlibs deleted
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
Can you explain what you mean by"adding permissions to everyone jcr:all"?I'm having the same issue and would love to know how you fixed it.Thanks!

Views

1.7K

Likes

0

Replies

0
Re: Publisher error when loading page - file not found
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
smacdonald2008 wrote... Try packaging up your content from author and then deploy to pub. This will ensure that all of your content does get deployed to pub instance. Hi,Yeah, I know that I could package up the content to deploy, but the point is that I should be able to publish from the Author without having to package and deploy.I guess I can try and package it up initially to work but the replication should really be taking care of this (and it did) and it doesn't make sense that it's not det...

Views

1.1K

Likes

0

Replies

0
Publisher error when loading page - file not found
Avatar
Give Back 5
Level 2
jackie_chan_
Level 2

Likes

8 likes

Total Posts

11 posts

Correct reply

0 solutions
Top badges earned
Give Back 5
Ignite 3
Give Back 3
Give Back
Ignite 1
View profile
jackie_chan_
- Adobe Experience Manager
Hi everyone,I've set up separate author and publisher instances on separate servers. I edited the Default Agent on the Author to point to the Publisher's server and everything seems good there.I pushed out my components, content, and designs using the Activate Tree page and looking at CRX on the Publisher, everything is there that should be from the Author.However, when I load up a page, it's complaining that it can't find a file referenced in one of jsps, even though it DOES exist on the Publis...

Views

1.1K

Likes

0

Replies

2