Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Unable to upload images in 6.5 author using dispatcher url

Avatar

Level 4

Hi All,

We have setup new DEV and QA AEM instances along with dispatcher for author i.e. https://dev-author.xxx.com.

But we are unable to upload assets using author dispatcher url, could not find any errors in author dispatcher.log or AEM server logs related to this.

The same users are able to upload images using author ip address.

In author dispatcher filters, we have allowed all but denied admin tools related url.

Are we missing anything?

 

Any inputs on this would be helpful.

 

Thanks

Srikanth Pogula.

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@srikanthp689160 
Do you see any error in the network tab when you upload the image? A 403 error like? If yes, it could be due to a dispatcher or a firewall block. Since you have already verified dispatcher rules, please look out for firewall rules.

All the domain URLs are usually behind a firewall, which are governed by rules called Web Application Firewall (WAF) rules.

I recommend you to verify these WAF rules and see if the AEM requests for Image upload are being blocked by one of such rule.

View solution in original post

4 Replies

Avatar

Correct answer by
Community Advisor

@srikanthp689160 
Do you see any error in the network tab when you upload the image? A 403 error like? If yes, it could be due to a dispatcher or a firewall block. Since you have already verified dispatcher rules, please look out for firewall rules.

All the domain URLs are usually behind a firewall, which are governed by rules called Web Application Firewall (WAF) rules.

I recommend you to verify these WAF rules and see if the AEM requests for Image upload are being blocked by one of such rule.

Avatar

Level 4

Hi fanindras,

I don't see any 403 or other error in network tab or browser console. After image upload, page just refreshes but unable to find the image.

 

Thanks

Srikanth

Avatar

Level 4

@Fanindra_Surat, I could not find any image upload POST call entry. I checked in Stage author instance and i could not find here too.

Can you please provide more details for example url of image upload POST call

 

Thanks

Srikanth