Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.
SOLVED

Unable to deploy WKND code in AEMaaCS

Avatar

Level 9

I want to have some sample content in AEM cloud instance so I planned to use the WKND website. Initially I tried to download the zip from git release note (https://github.com/adobe/aem-guides-wknd/releases/download/aem-guides-wknd-3.2.0/aem-guides-wknd.all... and tried to install through package manager directly on AEM Dev cloud instance. But it failed to install the package due to the following error - Package (or its subpackage(s)) contains application content which isn't supported at runtime. I knew that the package which I am trying to install contains both mutable and immutable (application code). which is why the system gives me the above error.

 

So an alternate option I want to install this WKND through cloud manager pipeline so I set up a new repo and dump all the code and created a new pipeline for the deployment. But when I start a pipeline I get the below error immediately, 

 

 

 

Cloning into 'weekend'...
Warning: Permanently added the RSA host key for IP address 'xx' to the list of known hosts.


Already on 'main'
Your branch is up to date with 'origin/main'.


[BUILD] Running git change-log command(s)
[BUILD] Running npm audit command(s)
Executing command npm --progress false audit --production --audit-level=critical
npm ERR! code EAUDITNOPJSON
npm ERR! audit No package.json found: Cannot audit a project without a package.json

npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2023-08-30T07_41_42_361Z-debug.log

 

 

AFAIK this package.json and package.lock.json is required only for Node js. I am not sure why I am getting this error in WKND code. Has anyone faced this issue ?

1 Accepted Solution

Avatar

Correct answer by
Employee

Please check whether the pipeline is created with full stack. You might have created a pipeline with Front end that is why it is looking for package.json

View solution in original post

2 Replies

Avatar

Correct answer by
Employee

Please check whether the pipeline is created with full stack. You might have created a pipeline with Front end that is why it is looking for package.json