Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Touch UI Richtext (RTE) sourceedit is not saving

mohammadm377380
Level 2
Level 2

Hi,

I just want to know if someone experiencing their Touch UI's RTE is not saving when it is viewed in sourceedit mode.

We have multifield with description that has sling:resourceType: cq/gui/components/authoring/dialog/richtext

Every time we want to edit a text inside using sourceedit and click check mark to save, it actually doesn't save.

It will save only once you click sourceedit icon again then you see the result then that's the time you click the check mark.

Another point is whenever your toggle sourceedit and click outside, you won't be able to see the toolbar again unless you close the dialog box.

1 Accepted Solution
Ratna_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi Mohammad,

Yes, I am able to reproduce this issue with Source edit in RTE.

This is a bug - I suggest you to raise the support ticket for the same.

sourceedit.PNG

Thanks,

Ratna.

View solution in original post

2 Replies
Hemant_arora
Level 8
Level 8

what version of AEM are you using, let me try to reproduce it.

smacdonald2008
Level 10
Level 10

Please post a screen shot of what you are experiencing.

mohammadm377380
Level 2
Level 2

Here are the screenshots regarding the disappearance of toolbar after triggering sourceedit icon.

1. Default toolbar after clicking the RTE area

with_toolbar_before_clicking_sourceedit.png

2. After clicking source edit

with_toolbar_after_clicking_sourceedit.png

3. Now after clicking outside the gray area

no_toolbar_after_sourceedit.png


The only way we can have the toolbar again is when we close the dialog.

We also are unable to save the content when it is on "sourceedit" mode.

Ratna_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi Mohammad,

Yes, I am able to reproduce this issue with Source edit in RTE.

This is a bug - I suggest you to raise the support ticket for the same.

sourceedit.PNG

Thanks,

Ratna.

View solution in original post

mohammadm377380
Level 2
Level 2

Thanks for trying it Ratna.


I'll raise a ticket for this.

mahdern11613285
Level 1
Level 1

Hi,

I am facing the same issue. As soon as I click on the sourcedit button from the RTE toolbar, the attributes of the html gets stripped out. i.e for eg., if I had <a href="http://www.google.com">Link to Google</a>, after clicking the sourceedit button, it will change to <a>Google Link</a>. What is going in here? Where is the javascript that handles this inside the AEM...any help is appreciated.

smacdonald2008
Level 10
Level 10

It was established this is a bug - please open a ticket.

shivamurthym775
Level 2
Level 2

Hello smacdonald2008​,

Is there any solution for this issue?

I am also facing  the same issue..

Ratna_Kumar
Community Advisor
Community Advisor

Hi,

The issue still exists in AEM 6.4 as well.


Please raise support ticket for the same.

Thanks,

Ratna Kumar.