Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Select multiple tags in touch UI AEM 6.2

Avatar

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
swatid
Level 2

08-11-2017

Hi Team,

1. How can I store multiple tags in a component's node. I can select multiple tags in dialog but its not saving in JCR node, taking the first selection only.

Below is the screenshot showing all the properties I have used :

1343776_pastedImage_0.png

2. My tags data is not pertaining while reediting the component, I don't see the tags selected when I am reopening the dialog but it is stored in component node of jcr, Please help me to resolve this too.

Thanks in advance for your help.

Regards,
SD

Replies

Avatar

Avatar
Validate 10
Level 4
mjb54261515
Level 4

Likes

33 likes

Total Posts

132 posts

Correct Reply

32 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 25
View profile

Avatar
Validate 10
Level 4
mjb54261515
Level 4

Likes

33 likes

Total Posts

132 posts

Correct Reply

32 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 25
View profile
mjb54261515
Level 4

08-11-2017

This is not an issue with OOOB tag widget AEM provides. I just tested in AEM 6.2. It works fine.

I have attached screen shots too.

1343880_pastedImage_0.png

1343881_pastedImage_1.png

following are sample tag widget snippets that might help.

<tags

                                                cq:showOnCreate="{Boolean}true"

                                                jcr:primaryType="nt:unstructured"

                                                sling:resourceType="cq/gui/components/common/tagspicker"

                                                allowBulkEdit="{Boolean}true"

                                                allowCreate="{Boolean}true"

                                                cq-msm-lockable="cq:tags"

                                                fieldLabel="Tags"

                                                name="./cq:tags"

                                                renderReadOnly="{Boolean}true"/>

<tags

                    jcr:primaryType="cq:Widget"

                    cls="cq-propsdialog-tags"

                    fieldLabel="Tags/Keywords"

                    name="./cq:tags"

                    xtype="tags"/>

Avatar

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
swatid
Level 2

08-11-2017

Hi there,

I tried the cq:dialog tags field of page component but still not accepting multiple tags. Its storing the tags as String not as String[] in jcr with single value.

I also used the extra clientlibs of page component but still not working.

1344337_pastedImage_1.png

1344353_pastedImage_2.png

Appreciate your more suggestions.

Thanks,

SD

Avatar

Avatar
Validate 10
Level 4
mjb54261515
Level 4

Likes

33 likes

Total Posts

132 posts

Correct Reply

32 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 25
View profile

Avatar
Validate 10
Level 4
mjb54261515
Level 4

Likes

33 likes

Total Posts

132 posts

Correct Reply

32 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 25
View profile
mjb54261515
Level 4

09-11-2017

Never came across this. I tested this again in AEM 6.2 touch ui working fine for me.

smacdonald2008​ any thoughts ?

Avatar

Avatar
Validate 1
Level 3
arjun07180302
Level 3

Likes

14 likes

Total Posts

36 posts

Correct Reply

8 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
arjun07180302
Level 3

Likes

14 likes

Total Posts

36 posts

Correct Reply

8 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
arjun07180302
Level 3

09-11-2017

I too validated on AEM 6.2 and it works perfectly fine.  Not sure why it is not working for you. Did you take a look the previous's reply by mjb54261515 which talks about an OOTB page (trainage page in geometrixx)? also please compare your custom component's dialog nodes and properties with with the OOTB one which is present in /libs/foundation/components/page/tab_basic/items/basic/items/tags

let us know if you are still running into issues. Also, package your component and upload it here. I will install it on my local and check it out.

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,167 likes

Total Posts

6,285 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,167 likes

Total Posts

6,285 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

09-11-2017

Can you reproduce this on the fresh instance? Also, check the error.logs if the problem still persists.

Avatar

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
swatid
Level 2

13-11-2017

Hi All,

Thanks all for your responses.

I tried to use tags under multifield, it's creating tags as a string not string[].

I am not able to attach the package so sending you screenshots only:

<questions

                        jcr:primaryType="nt:unstructured"

                        sling:resourceType="granite/ui/components/foundation/form/multifield"

                        class="full-width"

                        eaem-nested="">

                        <field

                            jcr:primaryType="nt:unstructured"

                            sling:resourceType="granite/ui/components/foundation/form/fieldset"

                            name="./questions">

                            <layout

                                jcr:primaryType="nt:unstructured"

                                sling:resourceType="granite/ui/components/foundation/layouts/fixedcolumns"

                                method="absolute"/>

                            <items jcr:primaryType="nt:unstructured">

                                <column

                                    jcr:primaryType="nt:unstructured"

                                    sling:resourceType="granite/ui/components/foundation/container">

                                    <items jcr:primaryType="nt:unstructured">

                                        <question

                                            jcr:primaryType="nt:unstructured"

                                            sling:resourceType="cq/gui/components/authoring/dialog/richtext"

                                            fieldLabel="Question :"

                                            name="./question">

                                            <rtePlugins jcr:primaryType="nt:unstructured">

                                                <paraformat

                                                    jcr:primaryType="nt:unstructured"

                                                    features="*"/>

                                                <spellcheck

                                                    jcr:primaryType="nt:unstructured"

                                                    features="*"/>

                                                <format

                                                    jcr:primaryType="nt:unstructured"

                                                    features="*"/>

                                                <edit

                                                    jcr:primaryType="nt:unstructured"

                                                    features="*"/>

                                                <findreplace

                                                    jcr:primaryType="nt:unstructured"

                                                    features="*"/>

                                            </rtePlugins>

                                        </question>

                                        <tags

                                            cq:showOnCreate="{Boolean}true"

                                            jcr:primaryType="nt:unstructured"

                                            sling:resourceType="cq/gui/components/common/tagspicker"

                                            allowBulkEdit="{Boolean}true"

                                            allowCreate="{Boolean}true"

                                            cq-msm-lockable="cq:tags"

                                            fieldLabel="Tags"

                                            name="./cq:tags"

                                            value="String[]"/>

                                    </items>

                                </column>

                            </items>

                        </field>

                    </questions>

1347307_pastedImage_8.png

Thanks,

SD

Avatar

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
swatid
Level 2

14-11-2017

Hi Team,

Can you please retest with selecting multiple tags inside multifield as shown above.

Thanks in advance for your help.

Regards,

SD

Avatar

Avatar
Validate 1
Level 2
kumaranf
Level 2

Likes

2 likes

Total Posts

19 posts

Correct Reply

6 solutions
Top badges earned
Validate 1
Boost 1
Applaud 5
Affirm 5
Affirm 3
View profile

Avatar
Validate 1
Level 2
kumaranf
Level 2

Likes

2 likes

Total Posts

19 posts

Correct Reply

6 solutions
Top badges earned
Validate 1
Boost 1
Applaud 5
Affirm 5
Affirm 3
View profile
kumaranf
Level 2

14-11-2017

If you select only one tag, it will be stored as a String. Once stored as String it will continue to be String (comma separated) even if you try editing the field and adding multiple tags.

Try saving multiple values in the first attempt itself (i.e. before the property exists in AEM).

Avatar

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 2
swatid
Level 2

Likes

2 likes

Total Posts

13 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
swatid
Level 2

14-11-2017

I selected multiple tags at first edit only but still not saving.

Even in reediting the dialog its not saving in array.