Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Saml Login fails : getting error "com.adobe.granite.auth.saml.util.SamlReader Document is invalid: no grammar found."

Avatar

Avatar
Validate 10
Level 3
anushap40132887
Level 3

Likes

8 likes

Total Posts

52 posts

Correct Reply

3 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 3
anushap40132887
Level 3

Likes

8 likes

Total Posts

52 posts

Correct Reply

3 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
anushap40132887
Level 3

12-06-2018

I have configured saml in aem 6.3 following this documentation, http://www.aemstuff.com/blogs/july/saml.html

It is working fine in publish, but in author I am getting below exception some times and login fails.

12.06.2018 10:39:13.096 *ERROR* [qtp45451009-84563] com.adobe.granite.auth.saml.util.SamlReader Document is invalid: no grammar found.

12.06.2018 10:39:13.096 *ERROR* [qtp45451009-84563] com.adobe.granite.auth.saml.util.SamlReader Document root element "Response", must match DOCTYPE root "null".

and in the page it shows,

This page contains the following errors:

error on line 1 at column 1: Document is empty

Below is a rendering of the page up to the first error.

Anyone faced similar issue? Please advice?

Replies

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,164 likes

Total Posts

6,273 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,164 likes

Total Posts

6,273 posts

Correct Reply

1,144 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

13-06-2018

Are you getting just those 2 errors in the log or any more? Please share other errors also if there are somemore.

If those are only 2 then See:SAML Grammar response Error/Warning

-Kautuk

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,408 likes

Total Posts

12,671 posts

Correct Reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

13-06-2018

Avatar

Avatar
Validate 1
Level 4
cqsapientu69896
Level 4

Likes

22 likes

Total Posts

76 posts

Correct Reply

4 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 10
Give Back
View profile

Avatar
Validate 1
Level 4
cqsapientu69896
Level 4

Likes

22 likes

Total Posts

76 posts

Correct Reply

4 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 10
Give Back
View profile
cqsapientu69896
Level 4

03-07-2018

Hi anushap40132887

We are getting the same error in the logs, but SAML authentication is working fine. Could you please let us know if you were able to find resolution of this issue?

Thanks

Avatar

Avatar
Validate 10
Level 3
anushap40132887
Level 3

Likes

8 likes

Total Posts

52 posts

Correct Reply

3 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 3
anushap40132887
Level 3

Likes

8 likes

Total Posts

52 posts

Correct Reply

3 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
anushap40132887
Level 3

08-07-2018

Thanks cqsapientu69896437 for the reply. I have removed the saml configuration and reconfigured again and it started working for me after few hours.