Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!

RTE in multifield is not working as expected

Avatar

Level 4

Hi all,

I am using AEM 6.2 SP1 CFP9. I am running in to issues with rich text editor in multi field. I copied richtext present at  /libs/cq/gui/components/authoring/dialog/richtext in to apps. I created a component with multi field using ACS AEM Commons multi field widget, i have rich text in mutifield.

The problem is when i create link in RTE and save for the first time, link will be working. If i open the dialog and save RTE again even with out editing, It is removing href and saving the data.

For example: if i have link as <a href="https://forums.adobe.com/content/geo/a.html" target="_self">Link 1</a> in the first save. If i open the dialog and save it again, it is transforming to

<a target="_self">Link 1</a>"

Any thoughts on this issue would be helpful.

Thanks

25 Replies

Avatar

Level 10

"some Multi Filed issue with Acs commons" - then we would see this with Fresh instance - but it works.

I am going to test on Coral/Granite MF too - that one for 6.3 does not need an ACS-Commons.

Avatar

Level 1

@smacdonald2008

Am facing the same issue in 6.4,

When i reopen the dialog, am unable to see the content in RTE

Can you please help me with this.

I installed the package which you have shared in the above post.same issue with that package as well

Avatar

Level 2

Hi @nicolec5933381 ,

Is the issue is resolve as I am facing the same issue in multifield in RTE ? As the value is not getting saved in the richtext when opens the dialog.

Regards,

Swati

Avatar

Level 1

Hello

The issue with using RTE (cq/gui/components/authoring/dialog/richtext )  within multifield (granite/ui/components/coral/foundation/form/multifield)   still exists on 6.5 version. It doesnt store rte property in the nodesinstead it creates a seperate node Has anyone got any solution for this