Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

[AEM Gems Webinar] Accelerating Experience Manager as a Cloud Service development with Rapid Development Environments
SOLVED

RTE Hyperlink plugin prepends the author domain in 6.3

Avatar

Level 1

Hi Everyone,

I have an issue with RTE Hyperlink plugin, it is somehow prepending the author's domain to the internal links authored and after the publish, i see the link is still associated with the author domain only. Here is how it is happening:

Screen Shot 2018-01-23 at 1.32.16 PM.png

Can some help me out with this issue.

1 Accepted Solution

Avatar

Correct answer by
Level 10

I saw the similar issue in our environment sometime back, was fixed by CFP.[0]. You may want to try it.

[0] https://helpx.adobe.com/experience-manager/release-notes--aem-6-3-cumulative-fix-pack.html

View solution in original post

0 Replies

Avatar

Correct answer by
Level 10

I saw the similar issue in our environment sometime back, was fixed by CFP.[0]. You may want to try it.

[0] https://helpx.adobe.com/experience-manager/release-notes--aem-6-3-cumulative-fix-pack.html

Avatar

Level 10

I marked Praveen answer as correct as this looks like a known issue.

Avatar

Level 1

Thanks for your response guys, but it's not working.
I have installed these 2 packages:Screen Shot 2018-01-24 at 10.10.44 AM.pngScreen Shot 2018-01-24 at 10.10.32 AM.png

None of these files effect " libs/wcm " or " libs/foundation ".
The hyperlink is still prepending the author domain.
Screen Shot 2018-01-24 at 10.11.33 AM.png

Avatar

Level 1

FYI: it is fixed in 6.4 within the /libs/clientlibs/granite/richtext.js by using the addLinkToDom function parameter (url) and not the href that has been modified nativly by the browser.

attributes[CUI.rte.Common.HREF_ATTRIB] = url;