Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!
SOLVED

Postconstruct calling twice - maven arch 23 - aem 6.5.4

Avatar

Level 2

Anyone faced this issue ? post construct calling twice

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

6.5
1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@sathyaprakasha2 - 
I saw your logs, I suspect it's something related to cq-editor.

Try reinstalling  cq-ui-wcm-editor-content-1.1.350.zip package in crx/packmgr and restart your AEM instance once.

View solution in original post

7 Replies

Avatar

Community Advisor

@sathyaprakasha2,

Can you please share more detail about this situation? Can we see your sling model implementation?

Avatar

Level 2
Hi Brain.. Juz one liner code PageManager pageManager; private static final Logger log = LoggerFactory.getLogger(TopNav.class); @PostConstruct protected void init() { log.info("topnavigation called"); }

Avatar

Level 2

Team , its not related to postconstruct  . pls see the below logs

 

2020-08-11 11:35:38.272 DEBUG [com.sample.aem.core.filters.LoggingFilter] request for /libs/cq/gui/content/editor, with selector null
2020-08-11 11:35:38.272 DEBUG [com.sample.aem.core.filters.LoggingFilter] request for /libs/cq/gui/content/editor, with selector null
2020-08-11 11:35:38.431 DEBUG [com.sample.aem.core.filters.LoggingFilter] request for /libs/granite/csrf/token, with selector null
2020-08-11 11:35:38.431 DEBUG [com.sample.aem.core.filters.LoggingFilter] request for /libs/granite/csrf/token, with selector null
2020-08-11 11:35:38.500 DEBUG [com.sample.aem.core.filters.LoggingFilter] request for /libs/cq/i18n/dict, with selector en
2020-08-11 11:35:38.500 DEBUG [com.sample.aem.core.filters.LoggingFilter] request for /libs/cq/i18n/dict, with selector en

Avatar

Community Advisor
Do you have two of the same components on within the page?

Avatar

Level 2
No..I have deleted all the components...its not related to particular component n all..

Avatar

Correct answer by
Community Advisor

@sathyaprakasha2 - 
I saw your logs, I suspect it's something related to cq-editor.

Try reinstalling  cq-ui-wcm-editor-content-1.1.350.zip package in crx/packmgr and restart your AEM instance once.