Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

Pattern Detector suspicions around org.mozilla.javascript.debug and javax.script imports

katerynab215432
Level 1
Level 1

We are currently working on issues from Pattern Detector on AEM 6.4.8.4 version for potential upgrade to the 6.5.9 and we got next set of issues with NBCC/non.backwards.compatible.code type:

Spoiler
The OSGi import org.mozilla.javascript.debug, due to major package version change, referenced at bundle: xfa4j might no longer be resolvable
The OSGi import javax.script, due to package removal, referenced at bundle: com.adobe.livecycle.adobe-lc-forms-core might no longer be resolvable
The OSGi import javax.script, due to package removal, referenced at bundle: com.adobe.livecycle.scala-lang might no longer be resolvable

AEM Forms add-on has been installed with compatible version and we suppose that issue will get lost after AEM upgrade to 6.5.9 and Forms 6.5.9.0 Add-on upgrade, but issues are still present and we received more similar issues:

 

 

Spoiler
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=cc34584b941c05a3cf3d8eab89880069b37bf692603e14bf203477cf107c0c23 message="The OSGi import javax.script, due to package removal, referenced at bundle: org.apache.sling.api might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=21431baebde3e0103870d026127b52fe35724efa20e45066cdd3f3cca2cb36e7 message="The OSGi import org.apache.jackrabbit.oak.commons.io, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-blob-plugins might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=50a79803d2bc8583fb4fa085f2b2c3e6903ed2307b71d99a1311524be5d8a269 message="The OSGi import org.apache.jackrabbit.oak.stats, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-security-spi might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
 [SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=7e095bcf27724437aec0d614d249e79d9acae01bebd53bf845702a45f35d7af6 message="The OSGi import org.apache.jackrabbit.oak.commons, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-segment-azure might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=d6ed3c740d64a7c34ea1627027b7564cf5a2ef77314fc33a736e7831e27bd512 message="The OSGi import org.apache.jackrabbit.oak.cache, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-solr-osgi might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=2ea2b34519bf9f89fe9c769dc42031370873b88928d53b7f89d2196789910107 message="The OSGi import org.apache.jackrabbit.oak.commons.io, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-solr-osgi might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=c07274bb63e10c2387bb73c47ca398123cd3f8a279de86963755e446d5b67d95 message="The OSGi import org.apache.jackrabbit.oak.namepath, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-solr-osgi might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=ebc626970cb1ee21370543c61bcf432db65cd26d6fecd55f89935e53573a8dce message="The OSGi import org.apache.jackrabbit.oak.stats, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-solr-osgi might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=10fc47cbae6f5f604e5febff04f069554eb58caa4bd402c654d92376404c4522 message="The OSGi import org.apache.jackrabbit.oak.commons, due to major package version change, referenced at bundle: org.apache.sling.jcr.base might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=17bb7e0a5a78fd9b614eddefa47952c0e1ea364b687bda64cc1a66aa410567ad message="The OSGi import org.mozilla.javascript.debug, due to major package version change, referenced at bundle: xfa4j might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=886be083b40c6f0fcda3fa0f8e5032ce18a3d77418272843777c612cbb4cf44e message="The OSGi import javax.script, due to package removal, referenced at bundle: com.adobe.livecycle.adobe-lc-forms-core might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC
[SUSPICION] The pattern=NBCC/non.backwards.compatible.code was found by detector=IncompatibleExceptionDetector with id=72cf8b0400f47deecb00c82010e2767ad543354008b2ecdd556b61efbae6be3c message="The OSGi import javax.script, due to package removal, referenced at bundle: com.adobe.livecycle.scala-lang might no longer be resolvable". More info at=https://www.adobe.com/go/aem6_NBCC

 


How these problems could be resolved and what is the root cause of it? Thanks.

2 Replies
Jörg_Hoh
Employee
Employee

It seemst that the pattern detector reports ootb code (apache sling and apacke Oak bundles) not to adhere to these guidelines, which is at least confusing. Are you using the latest version of this tool?

katerynab215432
Level 1
Level 1

Hi, Jörg_Hoh!

We use the AEM 6.5.9.0 version with the AEM Forms 6.5.9.0 Add-on OSX/Win and the Pattern Detector 65. No custom deployed code/content/forms are present, pure AEM version.

This AEM package seems to be without any issues but we have these 13 suspicions on AEM 6.4.8.4 and 6.5.9.0 versions either. Find issues report below.

Does it mean that we should ignore them without doubts that anything will work incorrectly? For now we don't have any solutions for these OOTB issues but couldn't ignore them without your recommendations.

Thanks in advance for any help.


11 August 2021 12:47:01 EEST	NBCC	non.backwards.compatible.code	The OSGi import javax.script, due to package removal, referenced at bundle: org.apache.sling.api might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	org.apache.sling.api/javax.script
Referencing:	removal@javax.script
11 August 2021 12:47:01 EEST	NBCC	non.backwards.compatible.code	The OSGi import org.apache.jackrabbit.oak.commons.io, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-blob-plugins might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	org.apache.jackrabbit.oak-blob-plugins/org.apache.jackrabbit.oak.commons.io
Referencing:	change@org.apache.jackrabbit.oak.commons.io
11 August 2021 12:47:01 EEST	NBCC	non.backwards.compatible.code	The OSGi import org.apache.jackrabbit.oak.stats, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-security-spi might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	org.apache.jackrabbit.oak-security-spi/org.apache.jackrabbit.oak.stats
Referencing:	change@org.apache.jackrabbit.oak.stats
11 August 2021 12:47:01 EEST	NBCC	non.backwards.compatible.code	The OSGi import org.apache.jackrabbit.oak.commons, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-segment-azure might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	org.apache.jackrabbit.oak-segment-azure/org.apache.jackrabbit.oak.commons
Referencing:	change@org.apache.jackrabbit.oak.commons
11 August 2021 12:47:01 EEST	NBCC	non.backwards.compatible.code	The OSGi import org.apache.jackrabbit.oak.cache, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-solr-osgi might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	org.apache.jackrabbit.oak-solr-osgi/org.apache.jackrabbit.oak.cache
Referencing:	change@org.apache.jackrabbit.oak.cache
11 August 2021 12:47:01 EEST	NBCC	non.backwards.compatible.code	The OSGi import org.apache.jackrabbit.oak.commons.io, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-solr-osgi might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	org.apache.jackrabbit.oak-solr-osgi/org.apache.jackrabbit.oak.commons.io
Referencing:	change@org.apache.jackrabbit.oak.commons.io
11 August 2021 12:47:01 EEST	NBCC	non.backwards.compatible.code	The OSGi import org.apache.jackrabbit.oak.namepath, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-solr-osgi might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	org.apache.jackrabbit.oak-solr-osgi/org.apache.jackrabbit.oak.namepath
Referencing:	change@org.apache.jackrabbit.oak.namepath
11 August 2021 12:47:01 EEST	NBCC	non.backwards.compatible.code	The OSGi import org.apache.jackrabbit.oak.stats, due to major package version change, referenced at bundle: org.apache.jackrabbit.oak-solr-osgi might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	org.apache.jackrabbit.oak-solr-osgi/org.apache.jackrabbit.oak.stats
Referencing:	change@org.apache.jackrabbit.oak.stats
11 August 2021 12:47:01 EEST	NBCC	non.backwards.compatible.code	The OSGi import org.apache.jackrabbit.oak.commons, due to major package version change, referenced at bundle: org.apache.sling.jcr.base might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	org.apache.sling.jcr.base/org.apache.jackrabbit.oak.commons
Referencing:	change@org.apache.jackrabbit.oak.commons
11 August 2021 12:47:02 EEST	NBCC	non.backwards.compatible.code	The OSGi import javax.script, due to package removal, referenced at bundle: com.adobe.cq.dam.cq-scene7-imaging might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	com.adobe.cq.dam.cq-scene7-imaging/javax.script
Referencing:	removal@javax.script
11 August 2021 12:47:02 EEST	NBCC	non.backwards.compatible.code	The OSGi import org.mozilla.javascript.debug, due to major package version change, referenced at bundle: xfa4j might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	xfa4j/org.mozilla.javascript.debug
Referencing:	change@org.mozilla.javascript.debug
11 August 2021 12:47:02 EEST	NBCC	non.backwards.compatible.code	The OSGi import javax.script, due to package removal, referenced at bundle: com.adobe.livecycle.adobe-lc-forms-core might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	com.adobe.livecycle.adobe-lc-forms-core/javax.script
Referencing:	removal@javax.script
11 August 2021 12:47:02 EEST	NBCC	non.backwards.compatible.code	The OSGi import javax.script, due to package removal, referenced at bundle: com.adobe.livecycle.scala-lang might no longer be resolvable

More info at the Knowledge Base.

Referenced by:	com.adobe.livecycle.scala-lang/javax.script
Referencing:	removal@javax.script
11 August 2021 12:47:02 EEST	FINISHED	Progressive status	
Emitted	145548 patterns	58 MB
Emitted	6.5 database(s)
Analysed	44748 items	33 MB
Found	13 suspicion(s)
Total time	0m 07s
Performance	25897 items/sec
Inspection status	0 problem(s)
Processing status	0 problem(s)