Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Page Preview issue

Kiran_Vedantam
Community Advisor
Community Advisor

When the preview button is pressed, the page loads continuously by not letting us click on the confirmation pop-up. This issue is seen only in the chrome browser and also in some content paths only. 

 

Tried increasing the Number of Calls per Request in "Apache Sling Main Servlet" but it did not help. Do we have any recommended value for this? Can anyone suggest a fix for this?

 

Thanks,

Kiran Vedantam.

 

1 Accepted Solution
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

Which version of AEM are you using? Are you using custom popup when click on preview?

View solution in original post

10 Replies
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

Which version of AEM are you using? Are you using custom popup when click on preview?

View solution in original post

Kiran_Vedantam
Community Advisor
Community Advisor
Hi @Arun, we are using AEM 6.4.7 and no custom popup is used
Arun_Patidar
Community Advisor
Community Advisor
Can you please share screenshot, what error are you getting?
Kiran_Vedantam
Community Advisor
Community Advisor
This is the error i can see in the log "page.js:274 Loaded the ACS Commons QR Code JavaScript but could not locate an configuration resource at [ /etc/acs-commons/qr-code/_jcr_content/config.json/contentpath]. Verify the config resource exists and and this user has access to said resource."
Kiran_Vedantam
Community Advisor
Community Advisor
Marked this answer as correct answer as we have some custom popup which is causing the issue.
BrianKasingli
Community Advisor
Community Advisor

@Kiran_Vedantam,

Can you please share the browser's console log and author's error.log file. This may be a side effect from your code base.

Kiran_Vedantam
Community Advisor
Community Advisor
Hi @BRAIN, apologies for the delay. I will share the logs in some time.
Kiran_Vedantam
Community Advisor
Community Advisor

Hi All, Thanks for the prompt response. The issue is actually happening because of our custom pop-up which is placed at the end of the page and is not visible. @kautuk_sahni can you please close this question as we are looking into it from our end.

 

Thanks,

Kiran Vedantam.

sunjot16
Employee
Employee

What errors do you see in the browser's Console tab?

What errors/messages do you see in the error.log file when you do a Page Preview on the affected content page/path?