Highlighted

Not able to find full screen mode on content fragment editor in 6.3.3

rajeevy89244319

01-03-2019

I am using AEM 6.3.3. As per below documentation, we should be able to to author fragment using full screen mode editor. But I don't see any option on content fragment to change the editor to full mode. Is there some configuration that needs to be enabled to have full screen editor feature in content fragments?

Variations - Authoring Fragment Content

Replies

Highlighted

Gaurav-Behl

MVP

01-03-2019

Could you share the relevant screenshot(s)?

The multi-line editor in CF should have cf-fullscreeneditor-icon  icon for enabling full-screen mode.

Highlighted

Gaurav-Behl

MVP

01-03-2019

You could use the "Toggle Side Panel" button on the top to make it full screen.

The screenshot cf-fullscreeneditor-icon  is taken from 6.4 instance. I just checked my 6.3 & 6.4 instances for same. My 6.3.3.2 is same as your screenshot.

Highlighted

rajeevy89244319

01-03-2019

Side panel in my screenshot is already expended. If I click Toggle button, it minimizes the side panel. Below is the screenshot on clicking of toggle button.Capture.PNG

I want to maximize the Rich Text editor to have all the controls but can't find a way.

Highlighted
Highlighted

Gaurav-Behl

MVP

02-03-2019

Per my understanding, toggle side panel is the only option available to make RTE full-screen. When you want to apply any available RTE cmds then you can toggle and shrink the width.

You can't have a maximize button in this case because the RTE plugins/commands are in the left rail and not on the top like AEM 6.4

Hope that makes sense.

Highlighted

rajeevy89244319

04-03-2019

Thanks Gaurav.

Does that mean that in 6.3.3, only way to show additional plugins like link, unlink, table etc is to manually add those using javascript code? Now since 6.4 already seems to have these plugin  when maximized so again on upgrade, this custom plugin code needs to be removed.

It would be helpful if 6.3 documentation is updated with proper screenshots. Right now it has same content as 6.4 which is not correct.

Thanks,

Rajeev

Highlighted