Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Need help BADLY !!

Avatar

Level 2

I have been tasked to move an old 6.1 AEM instance to new Azure VM's and we took the route of new installs and move the content to them and install it. I was able to do most of the content but for some content install its taking hell alot of time. 

Example as 30mb package with just content (jcr only and no images etc.,) its taking about 2 hours to install. 

When I look at the logs it complains about as below:

 

11.12.2020 04:55:44.107 *WARN* [discovery.connectors.common.runner.39a62bba-1273-435b-b9a7-6b4ed4d8a39d.checkForLocalClusterViewChange] org.apache.sling.discovery.impl.common.heartbeat.HeartbeatHandler checkForLocalClusterViewChange/.run: time since local instance last wrote a heartbeat is 1871111ms (heartbeatTimeoutMillis=300000, heartbeatIntervalMillis=30000 => maxMillisSinceHb=240000). Flagging us as (still) changing

11.12.2020 04:55:44.107 *INFO* [discovery.connectors.common.runner.39a62bba-1273-435b-b9a7-6b4ed4d8a39d.checkForLocalClusterViewChange] org.apache.sling.discovery.impl.common.heartbeat.HeartbeatHandler invalidateCurrentEstablishedView: invalidating slingId=39a62bba-1273-435b-b9a7-6b4ed4d8a39d, lastEstablishedViewId=879c2982-d362-4ea8-b526-cc67cfd3742f

 

Sometimes this:

 

11.12.2020 04:56:14.849 *INFO* [discovery.connectors.common.runner.ffc1175d-408a-4518-b939-6a2196eeea74.checkForLocalClusterViewChange] org.apache.sling.discovery.impl.common.heartbeat.HeartbeatHandler invalidateCurrentEstablishedView: invalidating slingId=ffc1175d-408a-4518-b939-6a2196eeea74, lastEstablishedViewId=c31c51db-814e-4b32-a305-79e68a615355
11.12.2020 04:56:29.388 *INFO* [discovery.connectors.common.runner.ffc1175d-408a-4518-b939-6a2196eeea74] org.apache.sling.discovery.base.commons.BaseDiscoveryService getTopology: undefined cluster view: NO_ESTABLISHED_VIEW] org.apache.sling.discovery.base.commons.UndefinedClusterViewException: current established view was marked as invalid


11.12.2020 04:50:59.664 *WARN* [pool-6-thread-2] org.apache.jackrabbit.oak.plugins.segment.SegmentNodeStore Failed to create checkpoint dae1d8e5-6fd5-4b88-8ac3-7fab2d8ab9f8 in 10 seconds.

 

Can someone please help how to overcome this issue? Restart is not an options for me everytime as i got 100+ packages for 30 mbs size each. I know it may not be the best way to migrate but we are too far now and want to see some experts here can help with above error or faced it anytime in past. 

 

Thanks

 

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

Instead of using packages you can copy the source repository backup to your target Azure instance. And then use crx2oak command line utility to copy the content from source folder to target crx-quickstart folder. The utility uses multiple arguments using which you can also control which paths to copy and which to exclude. 

 

For more details see this - https://experienceleague.adobe.com/docs/experience-manager-64/deploying/upgrading/using-crx2oak.html... 

 

View solution in original post

0 Replies

Avatar

Community Advisor

@bipin_bitla,

Can you provide more logs? there might be some automation tasks running in the backend via your custom code bundles. Try installing your content files in a clean AEM environment, with "nosamplecontent".

Lets see the results,
Brian.

Avatar

Correct answer by
Employee Advisor

Instead of using packages you can copy the source repository backup to your target Azure instance. And then use crx2oak command line utility to copy the content from source folder to target crx-quickstart folder. The utility uses multiple arguments using which you can also control which paths to copy and which to exclude. 

 

For more details see this - https://experienceleague.adobe.com/docs/experience-manager-64/deploying/upgrading/using-crx2oak.html... 

 

Avatar

Level 2
Yes but wont work for us as we wanted to do some clean up too. Either way I was able to fix it via tar compactiona and garbage collection and was able to migrate all content whats needed. thanks for help