Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

missing page property not showing in node(CRX/DE) but seen/available in view-as-published

Avatar

Level 7

TLDR: I cannot find a page property when checking the page properties in CRX/DE but the property value is showing up when checking view-as-published

---------

so I have a property called "fileReference" which just points to an image in the DAM (e.g. /content/dam/images/animals/frog.jpg). I checked the node (/content/mysite/en/animals/frog/jcr:content) and I cannot find the property there.

BUT when I view-as-published on the page, the property value is showing in the rendered page.

Additional tests:

  1. I checked prod author CRX/DE and the fileReference is still not showing. BUT view-as-published on the page shows the correct value.
  2. I tried on prod publisher1 and same results as author.
  3. As another test, I deleted the rendered page copy in the dispatcher1 (so a fresh copy is retrieved from pub1). When I viewed the page from dispatcher1, I can see the property value.
  4. I made a package of /content/mysite/en/animals/frog using CRX packmgr and when I uncompressed the files, the page property is not showing.
  5. I manually reassigned the image to the property and now I can see property in CRX/DE.
  6. As a last test, I repeat no.4 and I can see the image reference now in the compressed files.

Any ideas what's happening? Thanks

 

EDIT1: here's a sample of the fileReference when it's showing correctly in CRX/DE

Screen Shot 2022-04-01 at 2.15.17 PM.png

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

if I am not wrong using fileRerefence you are having functionality like the below one -

DEBAL_DAS_0-1648783267046.png

Here file would be stored like this -

DEBAL_DAS_1-1648783404339.png

In your case the node hierarchy should be  /content/yourpagepath/jcr:content/image/file/jcr:content , it's having all the necessary information like fileName, mixinType.

 

Are you observing similar node structure? Please check. 

View solution in original post

0 Replies

Avatar

Correct answer by
Community Advisor

if I am not wrong using fileRerefence you are having functionality like the below one -

DEBAL_DAS_0-1648783267046.png

Here file would be stored like this -

DEBAL_DAS_1-1648783404339.png

In your case the node hierarchy should be  /content/yourpagepath/jcr:content/image/file/jcr:content , it's having all the necessary information like fileName, mixinType.

 

Are you observing similar node structure? Please check. 

Avatar

Employee

This sounds like a permissions issue 

 

You should try and delete the page with an admin account to ensure this is the case and then make sure that the user who is deleting pages (or user group) has the correct permissions to delete.

Avatar

Level 7

I am admin though. (or at least the admin account provided to me by Adobe Managed Services).