Expand my Community achievements bar.

Radically easy to access on brand approved content for distribution and omnichannel performant delivery. AEM Assets Content Hub and Dynamic Media with OpenAPI capabilities is now GA.
SOLVED

Missing attibute on list item on style selection for component Text(v2)

Avatar

Level 2

Hi.

 

I'm having an issue with the style selection list for the component Text(v2)as  isn't rendering the "value" attribute of each option, making it unselectable.

 

As a reference I'm attaching two images, one is "working-style" which is from the Title(v3) component, where the list items have a value and the selection works, and the other is "broken-style" wich correspond to the Text(v2) componet where you can see the missed "value" attribue.

 

To clarify:

1. Both components are in the same template and page

2. All the styles reference real classes, in fact the same class is used in both components

3. This issue only happens when is in the cloud, if you test in local the selection works

4. In Text(v2) if you select and option it shows the check icon, but if you click outside the component and check the style again, the option is not selected.

 

Working style image (Title v3)

 

working-style.jpg

 

Broken style image (Text v2):

broken-style.jpg

 

Thnaks for your help.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @pixeldvx 

Could you please go to the template of this page and look for the text v2 component in the same container, there you would notice a button to open a component policy like below

ArpitVarshney_1-1674115548832.png

Click on this and then go to the Style tab, where you would notice the style with css classes. It might be possible, css classes are missing in the policy for the corresponding style name. Attaching a screenshot for reference.

ArpitVarshney_2-1674115710678.png

 

Regards,

Arpit Varshney

 

 

 

 

View solution in original post

3 Replies

Avatar

Community Advisor

Check policies for both the components.

Himanshu Jain

Avatar

Correct answer by
Community Advisor

Hi @pixeldvx 

Could you please go to the template of this page and look for the text v2 component in the same container, there you would notice a button to open a component policy like below

ArpitVarshney_1-1674115548832.png

Click on this and then go to the Style tab, where you would notice the style with css classes. It might be possible, css classes are missing in the policy for the corresponding style name. Attaching a screenshot for reference.

ArpitVarshney_2-1674115710678.png

 

Regards,

Arpit Varshney

 

 

 

 

Avatar

Level 2

Hi, thanks for your answer.

 

Both compoents have the classes assigned.

 

Below is the one for Text(v2), the one with the issue

 

pixeldvx_0-1674133163818.png

 

And below is the one for the Title (v3), the one that works

pixeldvx_1-1674133279243.png