Highlighted

Latest Communities Release

Avatar

Avatar

JK_Kendall

Avatar

JK_Kendall

JK_Kendall

05-12-2016

Latest Communities Releases :

For AEM 6.2

Latest Communities Feature Pack is FP2 

 

For AEM 6.1

Latest Communities Feature Pack is FP6

 

When posting questions, it is very helpful, at the least, to identify 

  • AEM version
  • Communities version
  • selected SRP
  • JVM version and other relevant technical requirements for 6.1 and 6.2.

- JK

Replies

Highlighted

Avatar

Avatar

Gdubz-57m2mu

Avatar

Gdubz-57m2mu

Gdubz-57m2mu

05-12-2016

Thanks so much for this, JK!

Quick question, will you also be pushing the Communities FP2 (1.10.111) API and JavaDoc JARs to the maven repo[1]?

[1] https://repo.adobe.com/nexus/content/repositories/releases/com/adobe/cq/social/cq-socialcommunities-...

Highlighted

Avatar

Avatar

dwalling

Employee

Avatar

dwalling

Employee

dwalling
Employee

06-12-2016

This should be available now. Sorry for the delay

Don

Highlighted

Avatar

Avatar

Gdubz-57m2mu

Avatar

Gdubz-57m2mu

Gdubz-57m2mu

08-12-2016

dwalling wrote...

This should be available now. Sorry for the delay

Don

 

The JavaDoc JAR files for 1.10.60 (FP1) and 1.10.111 (FP2) are unavailable (they're 404'ing) despite being listed in the repository.

https://repo.adobe.com/nexus/content/repositories/releases/com/adobe/cq/social/cq-socialcommunities-...
https://repo.adobe.com/nexus/content/repositories/releases/com/adobe/cq/social/cq-socialcommunities-...

Are they available online anywhere, similar to the 6.2 JavaDocs[1]?

[1] https://docs.adobe.com/docs/en/aem/6-2/develop/ref/javadoc/

Highlighted

Avatar

Avatar

JK_Kendall

Avatar

JK_Kendall

JK_Kendall

12-12-2016

Hi Greg,

There was a bug in the documentation link to the repository.

Using Maven for Communities now has the correct link : 

https://repo.adobe.com/nexus/content/groups/public/com/adobe/cq/social/cq-socialcommunities-api/1.10...

Sorry it took so long to clear this up.

- JK

Highlighted

Avatar

Avatar

hemantbellani-O

Avatar

hemantbellani-O

hemantbellani-O

10-04-2017

Hi JK,

Can you possibly throw some light on my below queries:

  1. How to setup We.Retail reference site / Demo Machine on a vanilla AEM 6.2 instance?

For We.Retail Reference site: Do you reckon that the steps as mentioned at : https://github.com/Adobe-Marketing-Cloud/aem-sample-we-retail -> How to build ? should be sufficient or is there more it that you may be aware of? 

For Demo Machine site: Do you reckon steps mentioned at : https://github.com/Adobe-Marketing-Cloud/aem-demo-machine/wiki -> Getting Started should be sufficient or there may be some more steps to it that you may be aware of ?

 

Besides above, I have the below two queries too:

2. Are AEM 6.2 SP 1  and AEM-6.2-SP1-CFP2 mandatory to be installed to set up the reference sites mentioned at #1 above? I ask so because the section : Installation Overview at : https://docs.adobe.com/docs/en/aem/6-2/deploy/communities.html#Latest%20Releases suggests to update AEM before installing communities, so would request clarity on this topic?

 

3. What are the AEM Communities specific development artifacts available OOTB in AEM 6.2 (even when we.retail isn't installed)? Could you possibly point me to specific paths within CRX/DE to help explore them further on a vanilla AEM 6.2 instance.

 

Here are the specifics of my environment/machine where I am trying to setup a reference of AEM Communities to explore it:

1. AEM version : AEM 6.2

2. Java version: 1.8.0_91

3. Maven version: Apache Maven 3.3.9

4. Communities version: I would be comfortable to explore and learn with whatever is compatible with We.Retail and/or Demo Machine reference implementations?

 

Thanks,

Hemant

Highlighted

Avatar

Avatar

Bertrand_de_Coa

Employee

Avatar

Bertrand_de_Coa

Employee

Bertrand_de_Coa
Employee

10-04-2017

On the first set of questions: With the demo machine, you first need to download the We.Retail add-on, this will get you the latest release for 6.2 and 6.3 from GitHub.com, including for Communities area.

Then you need to make sure:

- To set demo.communities.samples.weretail=true

- To select the We-Retail option when creating your demo environment

There's no dependency on service packs or cumulative fix packs to be installed first, although it is recommended.

On a vanilla instance, just look under /libs/social for the Communities artifacts.

hope this helps 

Highlighted

Avatar

Avatar

hemantbellani-O

Avatar

hemantbellani-O

hemantbellani-O

10-04-2017

Bertrand de Coatpont wrote...

On the first set of questions: With the demo machine, you first need to download the We.Retail add-on, this will get you the latest release for 6.2 and 6.3 from GitHub.com, including for Communities area.

Then you need to make sure:

- To set demo.communities.samples.weretail=true

- To select the We-Retail option when creating your demo environment

There's no dependency on service packs or cumulative fix packs to be installed first, although it is recommended.

On a vanilla instance, just look under /libs/social for the Communities artifacts.

hope this helps 

 

 

Thanks Bertrand - I will try these out and hopefully that should work out.