Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Invisible AEM 6.2 components post targeting

Avatar

Level 2

Hi Guys,

 

I'm using AEM 6.2 which is integrated with Target thru cloud services for a/b testing and rules based personalization. The logic works properly for both activity types, but there is a bug in the AEM author environment.

After targeting any components they look good unless I leave page. If I leave page or my session expire and I re-visit targeted page, components are invisible. I can see there are some border lines for each component, but the content itself is invisible.

 

blank comopnents.PNG

 

I can normally operate on any component and targeting works properly on publish instance, but it's difficult to work with some components when I can't see them.

 

I can't see any related errors in the console or AEM error.log

Help? 🤔

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Employee

We are not aware of a known issue with Components in a Targeting Mode. Can you verify that whenever you are back to your test page you are applying a proper audience for the targeted component?

View solution in original post

2 Replies

Avatar

Correct answer by
Employee

We are not aware of a known issue with Components in a Targeting Mode. Can you verify that whenever you are back to your test page you are applying a proper audience for the targeted component?

Avatar

Level 2

@berliant
I'm setting up A/B test activity which doesn't require any audience to be shared from Target. The activity and its experiences sit in the same AEM instance under "/campaigns" folder. I see the paths are properly selected and content offer is loaded successfully for all page versions but it comes invisible.