Expand my Community achievements bar.

Radically easy to access on brand approved content for distribution and omnichannel performant delivery. AEM Assets Content Hub and Dynamic Media with OpenAPI capabilities is now GA.
SOLVED

i'm getting this error while i try to open a page and slingModel is not rendering in the page

Avatar

Level 4

 In error.log:

11.05.2023 14:00:32.043 *ERROR* [[0:0:0:0:0:0:0:1] [1683793832002] GET /editor.html/content/testing.html HTTP/1.1] com.adobe.cq.msm.ui.servlet.IsSourceRenderCondition path /content/testing.html to check render condition is not valid

 

11.05.2023 14:14:45.117 *ERROR* [[0:0:0:0:0:0:0:1] [1683794685067] GET /editor.html/content/aem-libs/us/en.html HTTP/1.1] com.adobe.cq.msm.ui.servlet.IsSourceRenderCondition path /content/aem-libs/us/en.html to check render condition is not valid

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

This code has nothing to do with page rendering itself. This message is written as part of the /editor.html, which is the editing functioality.

View solution in original post

4 Replies

Avatar

Community Advisor

Hi @vkarthick 

 

The error message indicates that the render condition check for the given path is not valid. It's possible that there's an issue with the Sling Model, but it could also be caused by other factors. Here are some possible steps to try to resolve the issue:

  1. Check if the Sling Model is properly configured and registered. Ensure that the @Model annotation is present and the Sling Model is being registered in the @Model(adaptables = Resource.class) and @Inject annotations. Verify that the model class is also mapped to the correct resource type.

  2. Check if the JCR permissions for the path are correctly set. If the permissions are set incorrectly or are missing, it could prevent the content from being rendered. Ensure that the user has sufficient read permissions to access the resource.

  3. Check if there are any errors in the logs. Look for any stack traces or error messages that might help diagnose the issue.

  4. Check if the required bundles are active. Ensure that the required bundles are active in the OSGi console. You may need to install or activate a bundle if it's not currently active.

  5. Verify if there are any issues with the dispatcher. Make sure the dispatcher is properly configured and all the dispatcher rules are properly defined.

  6. If the above steps don't resolve the issue, try restarting the AEM instance or clearing the caches.

Avatar

Employee Advisor

Please ignore this. (It should not be logged at all.)

Avatar

Level 4

Page is not rendering though, only html content is rendering not sling model.

Avatar

Correct answer by
Employee Advisor

This code has nothing to do with page rendering itself. This message is written as part of the /editor.html, which is the editing functioality.