Expand my Community achievements bar.

Learn about Edge Delivery Services in upcoming GEM session
SOLVED

Groups missing after AEM-6.4.4 upgrade

Avatar

Level 3

Hello Everyone,

Recently we have upgraded our servers from 6.2 to AEM 6.4.4 and we observed that many groups created till 6.2 was removed from the servers.

Is it caused by 6.4 upgrade?

Is it known issue?

Is there any fix for this to recover deleted groups?

Thanks in Advance.

1 Accepted Solution

Avatar

Correct answer by
Level 3

We upgraded from 6.0 to 6.2, from  6.2 to 6.4 , and now 6.4 to 6.4.4

In every upgrade we found that some OOTB groups can get deprecated. or some new groups might show up.

A general practice which we follow for upgrade is...

1. Custom groups created by your team should be packaged and have merge or merge preserve mode.

2. Package your group and keep  a backup.

3. Install this package post upgrade.

View solution in original post

4 Replies

Avatar

Employee Advisor
  • Check if you have any nodes under "/var/upgrade/PreUpgradeBackup" from Crxde.
  • Check the upgrade.log for any errors while migration or upgrade
  • There is no known issue with 6.4.4 and groups should not be missing.
  • Do you see the groups missing without installing SP4?
  • You can use [1] to migrate the groups from existing 6.2 instance

[1] Migrate users, groups, and ACLs between AEM instances

Avatar

Level 3

Hi ,

I have checked all steps you have mentioned, except last 2.

This was an upgrade from 6.2 CFP-14 to AEM 6.4.4 directly and the groups which are missing are custom groups which we have created along the road. [Missing few not all]

Upgrade log was clean and successful.

I have read few more people complaining about the same issue.

Avatar

Correct answer by
Level 3

We upgraded from 6.0 to 6.2, from  6.2 to 6.4 , and now 6.4 to 6.4.4

In every upgrade we found that some OOTB groups can get deprecated. or some new groups might show up.

A general practice which we follow for upgrade is...

1. Custom groups created by your team should be packaged and have merge or merge preserve mode.

2. Package your group and keep  a backup.

3. Install this package post upgrade.

Avatar

Level 3

We have already upgraded to 6.4.4, but unfortunately we did not take any back-up of users/groups before upgrade.

I have few custom groups missing, so have created them again on server.

That seems only possible solution for me, thanks for looking into this.