Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Frequent Issues with Authoring AEM 6.5

viveksachdeva
Level 7
Level 7

Hey guys,

 

Recently I have started seeing that, AEM author starts throwing JS error and doesnt load any component. Starts happening after a few deployments. Needs a restart to bring it back to normal. Screenshot attached. Anyone else facing this issue?Screenshot 2021-01-06 at 2.27.00 PM.png

1 Reply
fanindras
Level 5
Level 5

Can you check the error log at that time and post your findings here. You could potentially find something there.

Anudeep_Garnepudi
Community Advisor
Community Advisor

@viveksachdeva 

Check if any of the custom client lib is having OOTB client lib categories. If we use OOTB categories, the custom js will be included as part of OOTB js and if the custom js is having any error, that might break the complete authoring interface.

viveksachdeva
Level 7
Level 7
If thats the case, restart of server should also not solve the issue right? But it works after restart..
Anudeep_Garnepudi
Community Advisor
Community Advisor

@viveksachdeva

Never know when that js object will be undefined/null. Better check you custom clientlibs with cq.authoring.editor/cq.authoring.editor.core categories and check where you are turning off the event. Have a condition before turning off.

Hope this will resolve your issue.

-AG

Anudeep_Garnepudi
Community Advisor
Community Advisor
Which AEM version it is? Tag search is enabled in Asset Finder side panel?
viveksachdeva
Level 7
Level 7
AEM v 6.5.7.. Asset side panel is default one with filter and search.. has tag based search as well