Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

flush agent works in publish instance, but got "no such agent: server111 flush" in author instance

Avatar

Level 2

Hi, all,

I configured a flush agent earlier, all was working fine. When I checked today, the agent on the publish instance is still working fine. but on author instance, when I clicked on /etc/replication --> agents.publish --> flush agent --> view log, I got this error: no such agent: flush agent.

Checked the error.log file, this is what I got:

18.02.2016 11:27:21.594 *ERROR* [xx.xx.xx.x [1455812841592] GET /libs/wcm/core/content/pageinfo.json HTTP/1.1] com.day.cq.wcm.core.impl.servlets.PageInfoServlet Request path does not resolve to a resource: /etc/replication/agents.publish/flush%20flush

What config might be wrong? How I can troubleshoot?

Thanks,

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Any agents configured under 'agents.publish' would work in publish instance. If you want to work for author instance, you need to configure the agents under 'agents.author'

View solution in original post

3 Replies

Avatar

Correct answer by
Community Advisor

Any agents configured under 'agents.publish' would work in publish instance. If you want to work for author instance, you need to configure the agents under 'agents.author'

Avatar

Level 2

You are correct. but my question is actually for the flush agent which is defined under "agents.publish", but it showed "No such agent" info when clicked on "View Log". I tried to understand why it gives such message when in fact it is working fine when checking on the publish through the console. sorry for the confusion.

Avatar

Level 2

since the flush agent only runs in publish instances, the status of the agent in author should be "inactive" and "no such agent". Thanks!