Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Failure to find com.adobe.aem:uber-jar:jar:6.5

Avatar

Level 2

Hi,

 

I'm creating a project with the archetypeVersion 27 for a SPA on AEM 6.5.0. But I am having the below error when I'm trying to deploy:

 

Failure to find com.adobe.aem:uber-jar:jar:6.5 in https://repo.adobe.com/nexus/content/groups/public was cached in the local repository, resolution will not be reattempted until the update interval of adobe-public-releases has elapsed or updates are forced

 

Any idea to resolve this issue?

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi,

What command did you use to generate the project?

from the error, it seems you have chosen aemVersion 6.5 instead of 6.5.0

aemVersioncloudTarget AEM version (can be cloud for AEM as a Cloud Service; or 6.5.5, 6.4.8for Adobe Managed Services or on-premise).

View solution in original post

8 Replies

Avatar

Level 2

I had seen that kind of solution before, but it's not correct for me. 

I downloaded from mvnrepository.com uber-jar to 6.5.0 but I am having the below error when I'm trying to deploy:

error reading .m2/repository/com/adobe/aem/uber-jar/6.5.0/uber-jar-6.5.0.jar; zip END header not found

Avatar

Community Advisor

Have you removed the classfier option from the dependency and tried to build the code?

<dependency>

     <groupId>com.adobe.aem</groupId>

     <artifactId>uber-jar</artifactId>

     <version>6.5.8</version>

     <scope>provided</scope>

</dependency>

Avatar

Level 2
when I ran my command maven with archetype the classfier option was not present

Avatar

Community Advisor

Hi @telpom,

Can you try to remove the uber-jar from your local repository (from .m2/repository/...) and build the project. 

If it is still not working, try with "-U" (Eg: mvn -U clean install -PautoInstallPackage)

Avatar

Correct answer by
Community Advisor

Hi,

What command did you use to generate the project?

from the error, it seems you have chosen aemVersion 6.5 instead of 6.5.0

aemVersioncloudTarget AEM version (can be cloud for AEM as a Cloud Service; or 6.5.5, 6.4.8for Adobe Managed Services or on-premise).

Avatar

Level 1

Hi Arun,

I need to generate AEM project based on archetype "30" adobe managed service(on premises)  but it gives me below error. Can you please share with me correct command or let me know the fix.

 

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:3.2.1:generate (default-cli) on project standalone-pom: startup failed:
[ERROR] General error during conversion: Conflicting module versions. Module [groovy-all is loaded in version 2.4.16 and you are trying to load version 2.4.8

 

Command which I have been using  for generating project archetype : mvn -B archetype:generate -DarchetypeGroupId=com.adobe.aem -DarchetypeArtifactId=aem-project-archetype -DarchetypeVersion=30 -DaemVersion="6.5.5" -DappTitle="My Site" -DappId="mysite" -DgroupId="com.mysite" -DfrontendModule=general -DincludeExamples=n 

Thanks in Advance

 

Avatar

Level 2

Executing the commands in below order fixed this issue for me -

1. mvn -U clean install 

2. mvn dependency:purge-local-repository