Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Failure to find com.adobe.aem:uber-jar:jar:6.5

telpom
Level 2
Level 2

Hi,

 

I'm creating a project with the archetypeVersion 27 for a SPA on AEM 6.5.0. But I am having the below error when I'm trying to deploy:

 

Failure to find com.adobe.aem:uber-jar:jar:6.5 in https://repo.adobe.com/nexus/content/groups/public was cached in the local repository, resolution will not be reattempted until the update interval of adobe-public-releases has elapsed or updates are forced

 

Any idea to resolve this issue?

1 Accepted Solution
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

What command did you use to generate the project?

from the error, it seems you have chosen aemVersion 6.5 instead of 6.5.0

aemVersioncloudTarget AEM version (can be cloud for AEM as a Cloud Service; or 6.5.5, 6.4.8for Adobe Managed Services or on-premise).

View solution in original post

6 Replies
telpom
Level 2
Level 2

I had seen that kind of solution before, but it's not correct for me. 

I downloaded from mvnrepository.com uber-jar to 6.5.0 but I am having the below error when I'm trying to deploy:

error reading .m2/repository/com/adobe/aem/uber-jar/6.5.0/uber-jar-6.5.0.jar; zip END header not found

asutosh_jena
Community Advisor
Community Advisor

Have you removed the classfier option from the dependency and tried to build the code?

<dependency>

     <groupId>com.adobe.aem</groupId>

     <artifactId>uber-jar</artifactId>

     <version>6.5.8</version>

     <scope>provided</scope>

</dependency>

telpom
Level 2
Level 2
when I ran my command maven with archetype the classfier option was not present
Vijayalakshmi_S
Community Advisor
Community Advisor

Hi @telpom,

Can you try to remove the uber-jar from your local repository (from .m2/repository/...) and build the project. 

If it is still not working, try with "-U" (Eg: mvn -U clean install -PautoInstallPackage)

Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

What command did you use to generate the project?

from the error, it seems you have chosen aemVersion 6.5 instead of 6.5.0

aemVersioncloudTarget AEM version (can be cloud for AEM as a Cloud Service; or 6.5.5, 6.4.8for Adobe Managed Services or on-premise).

View solution in original post