Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Uber Jar 6.5.11 not getting downloaded in m2 repo

Avatar

Level 2

vjleo94_0-1639551458515.png

I am getting the error in the screenshot after I update my uber jar version in POM. I see that in the m2 Repo JAR file is not getting downloaded. Please help. 

 

Not able to access https://repo.adobe.com/nexus/content/groups/public/ as well in browser.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@vjleo94try something like this - update your profile adding additional repository.

        <profile>
            <id>adobe-public</id>

            <activation>
                <activeByDefault>true</activeByDefault>
            </activation>

            <properties>
                <releaseRepository-Id>adobe-public-releases</releaseRepository-Id>
                <releaseRepository-Name>Adobe Public Releases</releaseRepository-Name>
                <releaseRepository-URL>https://repo.adobe.com/nexus/content/groups/public</releaseRepository-URL>
            </properties>

            <repositories>
            	  <repository>
                      <id>central</id>
                      <name>Maven Repository Switchboard</name>
                      <url>https://repo1.maven.org/maven2</url>
                  </repository>
                  <repository>
                      <id>adobe-public-releases</id>
                      <name>Adobe Public Repository</name>
                      <url>https://repo.adobe.com/nexus/content/groups/public</url>
                      <releases>
                        <enabled>true</enabled>
                        <updatePolicy>never</updatePolicy>
                    </releases>
                    <snapshots>
                        <enabled>false</enabled>
                    </snapshots>
                </repository>
            </repositories>
            <pluginRepositories>
                <pluginRepository>
                    <id>adobe-public-releases</id>
                    <name>Adobe Public Repository</name>
                    <url>https://repo.adobe.com/nexus/content/groups/public</url>
                    <releases>
                        <enabled>true</enabled>
                        <updatePolicy>never</updatePolicy>
                    </releases>
                    <snapshots>
                        <enabled>false</enabled>
                    </snapshots>
                </pluginRepository>
            </pluginRepositories>
        </profile>
    </profiles>

View solution in original post

6 Replies

Avatar

Community Advisor

Hi @vjleo94, could you please try following options:

  1. Reorder repository in your settings.xml file - put maven repo before Adobe repo.
  2. Disable/remove Adobe repo from your settings xml.

I was able to download latest uber-jar version from maven repository e.g.

https://repo1.maven.org/maven2/com/adobe/aem/uber-jar/6.5.11/uber-jar-6.5.11.jar

https://repo.maven.apache.org/maven2/com/adobe/aem/uber-jar/6.5.11/uber-jar-6.5.11.jar

Avatar

Level 2

Hi @lukasz-m , Thank you for the reply. I am using the settings.xml similar to the one here 

https://helpx.adobe.com/experience-manager/kb/SetUpTheAdobeMavenRepository.html

 

Seems to only have the link of Adobe repo. Could you share the settings.xml config to be added ?

Avatar

Correct answer by
Community Advisor

@vjleo94try something like this - update your profile adding additional repository.

        <profile>
            <id>adobe-public</id>

            <activation>
                <activeByDefault>true</activeByDefault>
            </activation>

            <properties>
                <releaseRepository-Id>adobe-public-releases</releaseRepository-Id>
                <releaseRepository-Name>Adobe Public Releases</releaseRepository-Name>
                <releaseRepository-URL>https://repo.adobe.com/nexus/content/groups/public</releaseRepository-URL>
            </properties>

            <repositories>
            	  <repository>
                      <id>central</id>
                      <name>Maven Repository Switchboard</name>
                      <url>https://repo1.maven.org/maven2</url>
                  </repository>
                  <repository>
                      <id>adobe-public-releases</id>
                      <name>Adobe Public Repository</name>
                      <url>https://repo.adobe.com/nexus/content/groups/public</url>
                      <releases>
                        <enabled>true</enabled>
                        <updatePolicy>never</updatePolicy>
                    </releases>
                    <snapshots>
                        <enabled>false</enabled>
                    </snapshots>
                </repository>
            </repositories>
            <pluginRepositories>
                <pluginRepository>
                    <id>adobe-public-releases</id>
                    <name>Adobe Public Repository</name>
                    <url>https://repo.adobe.com/nexus/content/groups/public</url>
                    <releases>
                        <enabled>true</enabled>
                        <updatePolicy>never</updatePolicy>
                    </releases>
                    <snapshots>
                        <enabled>false</enabled>
                    </snapshots>
                </pluginRepository>
            </pluginRepositories>
        </profile>
    </profiles>

Avatar

Level 2

@lukasz-m , Added the new maven repo. Still getting the below error 

 

Could not find artifact com.adobe.aem:uber-jar:jar:apis:6.5.11 in central (https://repo1.maven.org/maven2).

Avatar

Level 2

Thanks a lot @lukasz-m . Classifier API is not available. Removing the classifier from all dependent pom.xml fixed the issue.

Avatar

Level 2

For me even after removing the classifier, it was not working. Following is the steps I followed to fix this issue.

 

1. Modify setting.xml in m2 user profile as suggested by @lukasz-m 

2. Run command : mvn -U clean install 

3. mvn dependency:purge-local-repository