Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Error During Rebuilding of clientlibs with GCC compiler

karansheel
Level 3
Level 3

Hi,

I have changed JS compressor from "min:yui" to "min:gcc" now while rebuilding clientlibs I'm getting exception for two clientlibraries. Here is list :

1./etc/clientlibs/granite/moment/legacy/moment.min.js

2. /libs/dam/gui/components/s7dam/carousel/editor/clientlibs/editor.min.js

Here is exception

java.io.IOException: Error while reading cached library: javax.jcr.RepositoryException: Error during assembly of /etc/clientlibs/granite/moment/legacy/moment.js

java.io.IOException: Error while reading cached library: javax.jcr.RepositoryException: Error during assembly of /libs/dam/gui/components/s7dam/carousel/editor/clientlibs/editor.js

If I changed it to YUI it doesn't through any error. But I have to use GCC. AEM version is "6.2.0.SP1-CFP4".

My question what is the root cause for these errors. How much it can impact the application i.e for which component these moment.min.js clientlibrary is getting used .

Can you please help.

1 Accepted Solution
Vish_dhaliwal
Correct answer by
Employee
Employee

Hello,

Sometimes, it fails due to syntax errors. Go to localhost:port/libs/granite/ui/content/dumplibs.rebuild.html, clear cache and rebuild the libraries.  Check if you get more detailed error messages in the logs.

Regards,

Vishu

View solution in original post

2 Replies
Vish_dhaliwal
Correct answer by
Employee
Employee

Hello,

Sometimes, it fails due to syntax errors. Go to localhost:port/libs/granite/ui/content/dumplibs.rebuild.html, clear cache and rebuild the libraries.  Check if you get more detailed error messages in the logs.

Regards,

Vishu

View solution in original post

BattiniSravan
Level 3
Level 3

Even after invalidating the cache on http://localhost:4502/libs/granite/ui/content/dumplibs.rebuild.html?back=true, up on rebuilding, I am facing the following errors.

Screenshot 2021-10-27 at 11.06.32 AM.png

 

I am rebuilding this because, my instance start page icons are not loading.

Screenshot 2021-10-27 at 11.07.51 AM.png

reference: https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/aem-6-5-8-icons-not-showin...