Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Eclipse AEM Plug-in not working with multiple projects

Avatar

Level 2

I have been using the AEM Eclipse Plug-In. I have the option to import/export from the server.

1787768_pastedImage_0.png

However, I have recently added another AEM project to Eclipse and am unable to import or export content.

1787769_pastedImage_1.png

The src/main/resources folder isn't able to be expanded and when I do click import from server, I get the following error: "No valid filter found in this project!"

1787770_pastedImage_2.png

Any idea on how to resolve this?

Thanks,

Francesca

9 Replies

Avatar

Community Advisor

Can you please tell me what it should import from CRXDE to src/main/resources. Can you try with other folders or node.

Avatar

Employee

Could be possible it is not a valid location, can you try with any other small project.

Avatar

Level 1

I faced this today, here is my solution:

 

Select Project

 

Right Click on it, configure -> convert to content project

 

Missing Filter is added and import works again

Avatar

Level 2

Click on CHANGE on repository import dialog and browse to  /src/main/content/jcr_root/apps rather than /src/main/resources . Hopefully this will solve the  problem.image.png

eclipse.PNG

Avatar

Level 2

sorry you have to browse until browse to /src/main/content/jcr_root/ only. It will solve the issue perfectly.

eclipse-checked.PNG