Expand my Community achievements bar.

SOLVED

Could not find artifact org.apache.commons:commons-imaging:jar:1.0-R1534292

Avatar

Level 5

Hi All, when I am trying to build the ALM project with autoInstallPackage parameter then maven build is getting failed and I am seeing below dependency error. But there is no any dependency set in project POM or manifest file. And without autoInstallPackage build is getting success. Could someone help, what could be the reason for this error.

 

Could not resolve dependencies for project com.adobe.learning:aem-learning-core:jar:1.0.1: Could not find artifact org.apache.commons:commons-imaging:jar:1.0-R1534292 in central (https://repo.maven.apache.org/maven2)

 

Thank you

Rashid

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@RashidJorvee Hope below URL is helpful

And also while triggering a local build try adobe-public parameter as well

 

mvn clean -PautoInstallPackage -Padobe-public -Dskip.npm=true -Dmaven.test.skip=true install

 

https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager-blogs/wknd-tutorial-projec...

 

0 Replies

Avatar

Correct answer by
Community Advisor

@RashidJorvee Hope below URL is helpful

And also while triggering a local build try adobe-public parameter as well

 

mvn clean -PautoInstallPackage -Padobe-public -Dskip.npm=true -Dmaven.test.skip=true install

 

https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager-blogs/wknd-tutorial-projec...

 

Avatar

Community Advisor

try updating correct dependency version or use adobe repo to download

 

<dependency>
              <groupId>io.wcm.maven</groupId>
              <artifactId>io.wcm.maven.aem-cloud-dependencies</artifactId>
              <version>2021.3.5087.20210322T071003Z-210225.0000</version>
              <type>pom</type>
              <scope>import</scope>
            </dependency>

 

Avatar

Level 1

Hi Arun,

We are using on-premise AEM6.5 and getting same dependency error while doing build using same above command.

Failed to collect dependencies at io.wcm:io.wcm.testing.aem-mock.junit4:jar:2.6.0 -> io.wcm:io.wcm.testing.aem-mock.core:jar:2.6.0 -> org.apache.commons:commons-imaging:jar:1.0-R1534292: Failed to read artifact descriptor for org.apache.commons:commons-imaging:jar:1.0-R1534292: Could not transfer artifact org.apache.commons:commons-imaging:pom:1.0-R1534292 from/to adobe (https://repo.adobe.com/nexus/content/groups/public/😞

Avatar

Community Advisor

Hi,

You can use the latest dependency for 

io.wcm.maven.aem-cloud-dependencies

https://wcm.io/tooling/maven/aem-dependencies.html 

page footer