Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

content package not getting installed using install folder in ui.apps

Mayukh001
Level 1
Level 1

We are working to move towards Cloud Manager for our CI/CD.
We are using process mentioned here:
https://docs.adobe.com/content/help/en/experience-manager-cloud-service/implementing/developing/aem-...

But although I am keeping the zip content packages under "install" folder, in Stage it is only deploying in Publishers but not installing in Author.

Package deploys fine in both Auth and Publish in Dev and QA which have single Auth and single Pub.
Stage have 1 Auth and 2 Pubs.

 

Any pointer..?

1 Accepted Solution
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

Is your master branch has the same POM as non prod POM?
Can you also check if the package is getting copied or not in Stage?

View solution in original post

2 Replies
Arun_Patidar
Correct answer by
Community Advisor
Community Advisor

Hi,

Is your master branch has the same POM as non prod POM?
Can you also check if the package is getting copied or not in Stage?

View solution in original post

Mayukh001
Level 1
Level 1
yes, pom versions are same. How to check if the package is getting copied or not in Auth..?
Arun_Patidar
Community Advisor
Community Advisor
you can check via CRXDE or via package manager
VeenaK
Level 3
Level 3

Hi @Mayukh001 

Could you also please check on ACL's missing if any(since you've mentioned content packages) along with what @Arun_Patidar mentioned.

Mayukh001
Level 1
Level 1
Can you please confirm what you want me to check on ACL. I am checking package installation in crx/packmgr using admin id.
Mayukh007
Level 4
Level 4
I did not make any ACL change. Package was added here: by creating "/content/install", "/content/install.author", "/content/install.pubblish" folder under ui.apps/src/main/content/jcr_root/apps/
Mayukh007
Level 4
Level 4
HI, Yes, that issue got resolved by adding 2 folders under ui.apps called "install.author" and "install.publish" and copy-pasted the content package zip. When you run maven build it will install the package wither to author or author+publish. It has some limitation as well... If you need full detail and setup let me know.
giacomoverdi
Level 1
Level 1
Hi, I've created the folder ui.apps/install.author and put in it the content package. After the Cloud Manager deploy I'can't see the package installed on Crxde. Any suggests?