Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Connected Asset Configuration User Group for RemoteDAM

Avatar

Level 2

Hi All,

I am trying to oob basic setup between Site Experience Manager to Asset Experience Manager using Connected Assets in 6.5 environment.

In the below screen for remote i created a new user remotedamuser in asset instance and provided author access as defined in https://experienceleague.adobe.com/docs/experience-manager-65/assets/using/use-assets-across-connect...

and for local user i had created a sites user "siteauthor" with author and dam user access as mentioned in above adobe site.

 

When i test connection its failing. Whereas when i change the remote user access with administrator it works.I tried adding even "dam user" group for remote user"remotedamauthor" but still same issue only when i add administrator group to this user it works.

 

rajaram33_0-1637978306852.png

 

rajaram33_1-1637979440251.png

 

Please suggest does the remote asset user need to be part of administrator group?

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @rajaram33, I am not sure if you are using any SP on your AEM 6.5. I did some tests on AEM 6.5 with SP10, and I have following observation that I hope will help you. In general the key part for the user you are using, is to make sure that he has jcr:read and jcr:write permission to root / location of the repository. I've prepared simple group with read only access to main folder (apps, content, libs) and with jcr:write permission to /, and it works.

Please have a look on below screen shot that shows details of my group under /useradmin view.

acls.jpg

The column name is a bit misleading as it said Delete however it is connect with jcr:write permission.

Looking on the OOTB AEM group probably only administrators group has more privileges to / location, this is why it also works for administrators group members. But in general if you will follow above rule you should be able to successfully use other group not only administrators.

View solution in original post

0 Replies

Avatar

Correct answer by
Community Advisor

Hi @rajaram33, I am not sure if you are using any SP on your AEM 6.5. I did some tests on AEM 6.5 with SP10, and I have following observation that I hope will help you. In general the key part for the user you are using, is to make sure that he has jcr:read and jcr:write permission to root / location of the repository. I've prepared simple group with read only access to main folder (apps, content, libs) and with jcr:write permission to /, and it works.

Please have a look on below screen shot that shows details of my group under /useradmin view.

acls.jpg

The column name is a bit misleading as it said Delete however it is connect with jcr:write permission.

Looking on the OOTB AEM group probably only administrators group has more privileges to / location, this is why it also works for administrators group members. But in general if you will follow above rule you should be able to successfully use other group not only administrators.

Avatar

Level 2

Hi @lukasz-m  I hope this is a bug with permissions. I am using 6.5.9 version even when we allocate dam user group connected asset test is failing.In addition to dam user only when we provide modify permission on Lib /dam folder it works. As shown below

rajaram33_0-1638038884632.png

 

Avatar

Level 2

Hi @Arun_Patidar  i had tried the same as mentioned in the document(i had stated the same in my above thread) .If you observe in this link they had asked to add remote user to author group.I dont see anything other than that for remote dam instance. It doesnt works with that unless we add modify for /libs/dam permission.

Avatar

Community Advisor

Hi,

There will be 2 admin users on

1. AEM sites

2. Remote DAM

 

Sites administratorLocalExperience Manager administratorsadminSet up Experience Manager and configure integration with the remote Assets deployment.
Assets administratorRemoteExperience Manager administratorsadmin on remote Experience ManagerConfigure Cross-Origin Resource Sharing (CORS).

 

I would suggest to use both admin user for connection