Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

com.day.cq.mailer,version=[5.9,6) -- Cannot be resolved in AEM 6.3

sherybedrock
Level 3
Level 3

Hi all,

i'm trying to rum my project on AEM 6.3 but there is a dependency issue com.day.cq.mailer,version=[5.9,6) -- Cannot be resolved.

Any ideas?

4 Replies
smrithig3923894
Level 1
Level 1

I am getting same error, but the version shown is different.

com.day.cq.mailer,version=[5.6,6) -- Cannot be resolved

ravip64217791
Level 1
Level 1

I had the same issue. I have updated the pom with 6.3 uber jar and removed old social api which are deprecated and removed to get the code working for 6.3. Update/add 6.3 uber jar to pom file and it should fix the issue(How to Build AEM Projects using Apache Maven )

Feike_Visser1
Employee
Employee

If you build using a clean archetype, do you get the same?

ravip64217791
Level 1
Level 1

After updating the UberJar, I din't get this error. If that's what you asked. Earlier I had these errors.6.3_1.png