Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Bundle not startiing - Unresolved requirements

s1101v
Level 3
Level 3

Hi All - I am getting the below error. Because of this issue, the bundle is not getting resolved. Can someone help with this?

 

s1101v_0-1614661988676.png

03.02.2021 00:06:45.616 *ERROR* [ anonymous-nosite-127.0.0.1-777db039-8efb-4aec-80a5-04ac005ebd09 ] org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unable to resolve product-mgt-landing.core [658](R 658.1): missing requirement [product-mgt-landing.core [658](R 658.1)] osgi.wiring.package; (osgi.wiring.package=com.adobe.cq.wcm.core.components.internal.models.v1) Unresolved requirements: [[product-mgt-landing.core [658](R 658.1)] osgi.wiring.package; (osgi.wiring.package=com.adobe.cq.wcm.core.components.internal.models.v1)])
org.osgi.framework.BundleException: Unable to resolve product-mgt-landing.core [658](R 658.1): missing requirement [product-mgt-landing.core [658](R 658.1)] osgi.wiring.package; (osgi.wiring.package=com.adobe.cq.wcm.core.components.internal.models.v1) Unresolved requirements: [[product-mgt-landing.core [658](R 658.1)] osgi.wiring.package; (osgi.wiring.package=com.adobe.cq.wcm.core.components.internal.models.v1)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)

1 Accepted Solution
KiranVedantam1992
Correct answer by
Community Advisor
Community Advisor

Check the core.wcm.components.version and update it to the latest.

 

KiranVedantam1992_0-1614664829578.png

Hope this helps.

 

Thanks,

Kiran Vedantam.

View solution in original post

0 Replies
KiranVedantam1992
Correct answer by
Community Advisor
Community Advisor

Check the core.wcm.components.version and update it to the latest.

 

KiranVedantam1992_0-1614664829578.png

Hope this helps.

 

Thanks,

Kiran Vedantam.

View solution in original post

jbrar
Employee
Employee

Karan is right, This issue is related to core components version. Check [1] for more details:

 

[1] https://github.com/adobe/aem-core-wcm-components/releases

 

Jörg_Hoh
Employee
Employee

That package is not exported by the bundle (just checked it with version 2.13.4). If you want to extend these core components, please check the documentaiton at https://experienceleague.adobe.com/docs/experience-manager-core-components/using/developing/customiz...