Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

bundle dependencies not resolved

Avatar

Level 7

I have added following dependencies to an aem 6.5.13 applicaiton.

 

<dependency>
            <groupId>com.fasterxml.jackson.core</groupId>
            <artifactId>jackson-core</artifactId>
        </dependency>
        <dependency>
            <groupId>com.fasterxml.jackson.core</groupId>
            <artifactId>jackson-databind</artifactId>
        </dependency>
        <dependency>
            <groupId>com.fasterxml.jackson.core</groupId>
            <artifactId>jackson-annotations</artifactId>
        </dependency>
        <dependency>
            <groupId>com.fasterxml.jackson.dataformat</groupId>
            <artifactId>jackson-dataformat-xml</artifactId>
        </dependency>

bundle is going into "installed" status with above depencies not resolving on system/console/bundle


com.fasterxml.jackson.core,version=[2.15.0,3) can not resolved

 

Thanks,

Sri

 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@sreenu539 ,

I would try couple of things here

1) Make sure I have uber-jar dependency specified in the main pom.xl file matching the service pack installed. In your case, it should be 

<dependency>
   <groupId>com.adobe.aem</groupId>
   <artifactId>uber-jar</artifactId>
   <version>6.5.13</version>
   <scope>provided</scope>
</dependency>

2) Try lowering the the version of jackson dependencies to 2.13.0 in the main pom.xml dependency declaration and add <scope>provided</scope>

3) Mine is 6.5.15 and I have jackson-* bundles in active mode with version 2.13.0.

 

If 2.13.0 version doesn't work as well, try lowering the version until the bundles state changes to active.

 

Hope this helps!

 

 

View solution in original post

4 Replies

Avatar

Community Advisor

Make sure your UberJar or CloudSDK is set with the proper version referenced to what has been installed in your AEM development environment. 

Avatar

Community Advisor

Hi @sreenu539 

 

Can you please confirm these dependencies are added in both core and main pom.

 

Thanks,

Kiran Vedantam

Avatar

Correct answer by
Community Advisor

@sreenu539 ,

I would try couple of things here

1) Make sure I have uber-jar dependency specified in the main pom.xl file matching the service pack installed. In your case, it should be 

<dependency>
   <groupId>com.adobe.aem</groupId>
   <artifactId>uber-jar</artifactId>
   <version>6.5.13</version>
   <scope>provided</scope>
</dependency>

2) Try lowering the the version of jackson dependencies to 2.13.0 in the main pom.xml dependency declaration and add <scope>provided</scope>

3) Mine is 6.5.15 and I have jackson-* bundles in active mode with version 2.13.0.

 

If 2.13.0 version doesn't work as well, try lowering the version until the bundles state changes to active.

 

Hope this helps!