Highlighted

Automatically removing the link in RTE

Avatar

Avatar

kalyan_chakrav1

Avatar

kalyan_chakrav1

kalyan_chakrav1

07-03-2019

Hi,

In the RTE when we are linking to their respective pages. Every time I try to add a link, if I exit out and go to edit and open the dialog ,the hyperlinks get removed in RTE. Could anyone help me on this.

Thanks & Regards,

Kalyan

Replies

Highlighted

Avatar

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281
Gaurav-Behl
MVP

08-03-2019

check browser console and error.log for any errors/warnings. Does that happen on an internal link or external link?

Validate linkchecker config for your project as well.

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

08-03-2019

When you added this link in the Touch UI RTE - are you sure you clicked the Done button in the dialog. This saves the information.

Highlighted

Avatar

Avatar

kalyan_chakrav1

Avatar

kalyan_chakrav1

kalyan_chakrav1

08-03-2019

Hi smacdonald2008​,

Yes I clicked on Done button and saved but still it is removing the link.

Thanks & Regards,

Kalyan

Highlighted

Avatar

Avatar

kalyan_chakrav1

Avatar

kalyan_chakrav1

kalyan_chakrav1

08-03-2019

Hi @gauravb41175071,

We Don’t see any errors and it removing both for internal and external links.

Thanks & Regards,

Kalyan

Highlighted

Avatar

Avatar

shubhaga1

Avatar

shubhaga1

shubhaga1

10-03-2019

Hi Kalyan,

You have to  give anonymous user access in libs to make it work, please check and confirm

Highlighted

Avatar

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281

Avatar

Gaurav-Behl

MVP

Total Posts

1.1K

Likes

226

Correct Answer

281
Gaurav-Behl
MVP

11-03-2019

please share screenshots/logs/video in case you still face the issue

Highlighted

Avatar

Avatar

mr_chawla

Avatar

mr_chawla

mr_chawla

11-03-2019

Hi Kalyan,

I expect you are adding certain characters in the href attribute which your xss protection is not satisfying. I believe you might be getting error something like [1].

Please confirm.

Regards,

Sumeet Chawla.

[1]: org.apache.sling.xss.impl.HtmlToHtmlContentContext AntiSamy warning: The a tag contained an attribute that we could not process. The href attribute had a value of <some dummy value>. This value could not be accepted for security reasons. We have chosen to remove this attribute from the tag and leave everything else in place so that we could process the input.

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

11-03-2019

Nice suggestion!