Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Authentication Error

Jai1122
Level 5
Level 5

Hi Experts,

   In one of our higher regions, we face a weird issue in which i could access the felix console through admin credentials.

But when i try to access any other module like crxde or damadmin i am getting  a 503.

The log reads org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.

On investigating the felix console config manager, we see two Apache Sling Authentication Service, and in osgi components the following components has unstatisfied reference.  

I am not sure what is causing this issue. We configured one of the Apache Sling Authentication service to disable anonymous access. But i dont think that should cause any issue.

Please help us on this.

 

Thanks,

Jai

5 Replies
Opkar_Gill
Employee
Employee

Hi Jai,

when you start the instance there will likely be an exception/error which caused the repository not to start. This is why the OSGI container is available (/system/console) but not any of the repository consoles. Please check the error.log and identify the first exception that appears.

Regards,

Opkar

Jai1122
Level 5
Level 5

Hi Opkar,

  I checked the error logs and found the following error

Exception 1 in error log:

    07.06.2016 13:15:39.413 *ERROR* [qtp2134851840-83] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.
07.06.2016 13:15:39.413 *ERROR* [qtp2134851840-83] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: Possible reason is missing Repository service. Check AuthenticationSupport dependencies.

Exception 2 in error log:

    java.lang.IllegalStateException: Singleton pid supplied matching a previous factory pid org.apache.sling.engine.impl.auth.SlingAuthenticator
    at org.apache.felix.scr.impl.config.ConfigurableComponentHolder.getSingletonPidIndex(ConfigurableComponentHolder.java:492)
    at org.apache.felix.scr.impl.config.ConfigurableComponentHolder.configurationUpdated(ConfigurableComponentHolder.java:382)
    at org.apache.felix.scr.impl.config.ConfigurationSupport.configurationEvent(ConfigurationSupport.java:297)
    at org.apache.felix.cm.impl.ConfigurationManager$FireConfigurationEvent.sendEvent(ConfigurationManager.java:2032)
    at org.apache.felix.cm.impl.ConfigurationManager$FireConfigurationEvent.run(ConfigurationManager.java:2002)
    at org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:103)
    at java.lang.Thread.run(Thread.java:745)

Attaching the stack trace in start up logs as well.

 

But i could not diagonize much through them. Please help me out.

Opkar_Gill
Employee
Employee

The first error in the log is:

07.06.2016 12:26:44.125 *ERROR* [FelixStartLevel] com.adobe.granite.repository.impl.SlingRepositoryManager start: Uncaught Throwable trying to access Repository, calling stopRepository() java.lang.RuntimeException: org.apache.jackrabbit.oak.api.CommitFailedException: OakConstraint0030: Uniqueness constraint violated at path [/] for one of the property in [jcr:uuid] having value 21232f29-7a57-35a7-8389-4a0e4a801fc3 at org.apache.jackrabbit.oak.spi.lifecycle.OakInitializer.initialize(OakInitializer.java:64) at org.apache.jackrabbit.oak.Oak.createContentRepository(Oak.java:561) at com.adobe.granite.repository.impl.SlingRepositoryManager.createRepository(SlingRepositoryManager.java:428) at com.adobe.granite.repository.impl.SlingRepositoryManager.acquireRepository(SlingRepositoryManager.java:299)

There seems to be a similar OAK issue already filed: https://issues.apache.org/jira/browse/OAK-1846 

What was done on the system before this issue started? Did you deploy a new package or make any configuration changes?

Regards,

Opkar

Jai1122
Level 5
Level 5

Hi Opkar,

    As said in the question, we updated the configuration on Apache Sling Authentication Service to disallow anonymous access(unchecked allow anonymous access) and changed the default login page in CQSelector Configuration.

    Also we deployed a package of users from the working instance as specified here and once this package is deployed we restarted the instance. After that the issue started.

I doubt at the components that are not active. Details as follows.

   

Opkar_Gill
Employee
Employee

Did you do all the changes at the same time and then restart instance? 

To proceed you can either investigate the error(with daycare if required) or can you restore a backup from before the changes were made and try the configuration changes/installs one at a time, to see where the issue lies?

Regards,

Opkar

Jai1122
Level 5
Level 5

Hi opkar,

Yes, we did all the changes and restarted the instance. Also we had this problem already and so we started again from a fresh instance and ended up here again with same issue.

GK-AEM
Level 9
Level 9

Which version of AEM are you using it??

Thanks,

Kishore