Expand my Community achievements bar.

Radically easy to access on brand approved content for distribution and omnichannel performant delivery. AEM Assets Content Hub and Dynamic Media with OpenAPI capabilities is now GA.
SOLVED

Archetype 41 version 6.5.5 project build issue

Avatar

Level 2

I created a new project using below command

mvn -B archetype:generate -D archetypeGroupId=com.adobe.aem -D archetypeArtifactId=aem-project-archetype -D archetypeVersion=41 -D appTitle="My Site" -D appId="mysite" -D groupId="com.mysite.aem" -D artifactId="mysite-aem-project" -D version="0.0.1-SNAPSHOT" -D aemVersion="6.5.5" -D includeDispatcherConfig=n -D includeExamples=n  -D frontendmodule=general

its failing with below error

 

06.06.2023 10:35:34.409 *ERROR* [0:0:0:0:0:0:0:1 [1686027930963] GET /content/mysite/us/en.html HTTP/1.1] com.day.cq.wcm.core.impl.WCMDeveloperModeFilter Error during include of SlingRequestPathInfo: path='/content/mysite/us/en/jcr:content', selectorString='null', extension='html', suffix='null'
org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: Identifier core/wcm/components/commons/v1/templates/clientlib.html cannot be correctly instantiated by the Use API

 

  • Core bundle and the project bundle are all active and are running fine. 
  • Core content package earlier was 2.21.2, changes it to 2.17.12, still no luck.
  • AEM version  - 6.5.6

 

Further noticed the path "core/wcm/components/commons/v1/templates/clientlib.html" does not exist in core directory, therefore the page http://localhost:4502/editor.html/content/mysite/us/en.html throws above error.

Checked on colleague's machine, the same path does exist and the page opens normally, and the v1/templates/clientlib.html is also present on his machine.

Any idea why this clientlib.html reference is not present core/components... directory?

 

Thanks in advance team.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hello @prasanna-mohite ,
Can you try with matched version? Since you are using AEM 6.5.6 with Archetype 41, which Adobe does not recommend. https://github.com/adobe/aem-project-archetype/blob/develop/VERSIONS.md 
See this version of Historical Support and try with a matched one.

If possible update your AEM version. 

View solution in original post

4 Replies

Avatar

Employee Advisor

Hi,

 

The error indicates that the clientlib file "clientlib.html" is missing in the specified path "core/wcm/components/commons/v1/templates". Check if the file exists in the correct location and ensure all dependencies and packages are properly installed and activated.

Avatar

Correct answer by
Community Advisor

Hello @prasanna-mohite ,
Can you try with matched version? Since you are using AEM 6.5.6 with Archetype 41, which Adobe does not recommend. https://github.com/adobe/aem-project-archetype/blob/develop/VERSIONS.md 
See this version of Historical Support and try with a matched one.

If possible update your AEM version. 

Avatar

Community Advisor

Hi @prasanna-mohite ,

Can you compare the version of jdk and maven in your machine and another machine where it is working?

Here we are creating a new project with the command should not throw this error. Could be a version issue. Please verify the version once

Avatar

Community Advisor

Check if the Java version is 11 and the supported Maven version is there.

Also, run the maven command using the -X to see full debug logging.