Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM WKND SPA - 503

Avatar

Level 2

Hello,

I wanted to try the WKND SPA Tutorial, and running AEM off of the following:

  • Java 8
  • AEM 6.5.5
  • Maven 6.3.6
  • Archetype 27

I started off with a clean author instance with the service pack installed, and when I first perform the mvn clean install -PautoInstallSinglePackage it would build fine, until...

I turn off the AEM instance and then turn it back on, and then I get the following:

 

HTTP ERROR 503 AuthenticationSupport service missing. Cannot authenticate request.
URI:	/
STATUS:	503
MESSAGE:	AuthenticationSupport service missing. Cannot authenticate request.
SERVLET:	org.apache.felix.http.base.internal.dispatch.DispatcherServlet-6aacc3

 

EDITED 2021-06-11

I did find this error in the logs:

 

10.06.2021 14:48:18.089 *ERROR* [FelixDispatchQueue] aem-guides-wknd-spa.react.core FrameworkEvent ERROR (org.osgi.framework.BundleException: Unable to resolve aem-guides-wknd-spa.react.core [596](R 596.0): missing requirement [aem-guides-wknd-spa.react.core [596](R 596.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.api)(version>=1.29.0)(!(version>=2.0.0))) Unresolved requirements: [[aem-guides-wknd-spa.react.core [596](R 596.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.api)(version>=1.29.0)(!(version>=2.0.0)))])
org.osgi.framework.BundleException: Unable to resolve aem-guides-wknd-spa.react.core [596](R 596.0): missing requirement [aem-guides-wknd-spa.react.core [596](R 596.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.api)(version>=1.29.0)(!(version>=2.0.0))) Unresolved requirements: [[aem-guides-wknd-spa.react.core [596](R 596.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.api)(version>=1.29.0)(!(version>=2.0.0)))]
	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
	at java.base/java.lang.Thread.run(Thread.java:834)

 

When I tried to install com.day.cq.wcm.api package directly in the root pom file it will not install let alone fix the situation.

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @jeremy_trpka-pe 

 

Please upgrade the AEM service pack to 6.5.8.0 and validate. You should not be getting these issue any more.

Also it's preferred to run AEM 6.5 with JDK 11.

https://experienceleague.adobe.com/docs/experience-manager-learn/foundation/development/set-up-a-loc...

 

Thanks!

View solution in original post

0 Replies

Avatar

Level 5

Java 11 is the recommended version for AEM 6.5. Also I would suggest you to give some time to the instance to come up and after that if it does not work, check the logs for error.

Avatar

Level 2
I originally tried it with Java 11, and it gave me the same results.

Avatar

Correct answer by
Community Advisor

Hi @jeremy_trpka-pe 

 

Please upgrade the AEM service pack to 6.5.8.0 and validate. You should not be getting these issue any more.

Also it's preferred to run AEM 6.5 with JDK 11.

https://experienceleague.adobe.com/docs/experience-manager-learn/foundation/development/set-up-a-loc...

 

Thanks!

Avatar

Level 2
Right now, our company only has access to the 6.5.5 service pack so updating it to 6.5.8 may not be a viable solution.

Avatar

Level 2

I was given the 6.5.8 service pack, and that did fixed the solution.
I also switched to Java 11.

Avatar

Community Advisor

Hi @jeremy_trpka-pe,

Please check the error.log file completely including the rotated error.log files with previous dates (continue till you notice a file without any Error level) to arrive at the original cause. 

"503 AuthenticationSupport service missing" error has quite a few related reasons to it, hence the need for digging completely. 

Update this thread with the same if possible. 

Avatar

Community Advisor

Hi @jeremy_trpka-pe,

Thanks for sharing the details.  com.day.cq.wcm.api is available as part of Uber-jar and no need to mention explicitly. Try using classic profile(-Pclassic) along with autoInstallPackage profile for building WKND SPA project. 

But for 503 issue, did you get a chance to check previous day logs like say 09 June / 08 June ..