Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM project site pages are resulting blank page view

swathialeti
Level 2
Level 2

When i open any AEM project site page it resulting a blank page view, i had checked the view as published for the page then it shows me an error like this org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: org.apache.sling.api.SlingException: Cannot get DefaultSlingScript: Compilation errors in org/apache/sling/scripting/sightly/apps/core/wcm/components/container/v1/container/container_html.java: Line 43, column 1900 : com.adobe.cq.wcm.core.components.models.LayoutContainer cannot be resolved to a type.
Then i removed the existing project setup from my local and created the new project setup again then i build the solution and it is success but still the page is blank .

I checked into bundles then i got to know that this below package is missing. The below screenshot is taken when i manually tried to installed the package into bundles and on doing this i got to see some errors in this package.

swathialeti_0-1628232991345.png

 

How to automatically gets installed this package into bundles? The core components package version currently i'm using is 2.14.0 and service pack is 6.5.8 . Can i know what was the root cause of it and by the way the default AEM site i.e. we-retail site is working perfect only can see issue with project sites.

3 Replies
swathialeti
Level 2
Level 2
yes, i installed it but in Bundles that EWCM package is not getting added/installed
swathialeti
Level 2
Level 2
I had only installed the core.wcm.components.all-2.17.8.zip package, Should i need to install all from the link that you gave
Arun_Patidar
Community Advisor
Community Advisor

Hi,

You can check the core components dependecny in your project POM and adjust version which are availble in AEM instance.

swathialeti
Level 2
Level 2

Hi
I had changed the version to 2.17.8 and solution is build success but in Bundles i couldn't find any EWCM package and  when i searched for 2.17.8 package in same bundles i couldn't find any such package, i can see some packages with version 2.3.2 . Is it taking 2.3.2 version ?  In package manager i could see core.wcm.components.content and core.wcm.components.config is having 2.17.8 version and core.wcm.components.examples is having 2.3.2.

 

Arun_Patidar
Community Advisor
Community Advisor
2.3.2 was the installed version of core components since you added 2.17.8 now in the pcakage manager you have new one, but can you check the bundle version at /apps/core/wcm/install
Bimmi_Soi
Community Advisor
Community Advisor

Hi @swathialeti ,

 

Update your core component version using below link

https://github.com/adobe/aem-core-wcm-components/releases/

 

Install core.wcm.components.all-2.17.8.zip using crx/packmgr and let me know if you still face the issue

 

Hope this helps!!

 

Thanks

Bimmi_Soi
Community Advisor
Community Advisor
Update the core version using core.wcm.components.all-2.17.8.zip
swathialeti
Level 2
Level 2
yes, i have installed the same version, can see only some content on to the page, only few components are present and none of the experience fragments are showing . still the EWCMAMS package is not present in Bundles .
Bimmi_Soi
Community Advisor
Community Advisor

What do you mean by not present, either it should be in Active state or resolved but how can this be possible that it is not present.

swathialeti
Level 2
Level 2
yes, unfortunately it was not present in Bundles and the code build is success.