Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

aem instance not working

Avatar

Avatar
Level 1
hemanthm9258359
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
hemanthm9258359
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
hemanthm9258359
Level 1

15-04-2019

I am practising aem in my local. i updated java in my local and from then aem instance is not working. i cannot open author and publish instance. i can install aem once again but i might lose all the data. please help me on this. what should i do?

Replies

Avatar

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

186 likes

Total Posts

236 posts

Correct Reply

72 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

186 likes

Total Posts

236 posts

Correct Reply

72 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile
Ravi_Pampana
MVP

15-04-2019

Hi,

Which version of java you updated and what is the version of AEM you are using? Can you check error.log to see what is the exception/errors you are getting while opening author/publish instance.

Error log will present under /crx-quickstart/logs/error.log.

Please share the error logs which helps us to analyze further on your issue.

Also check After upgrading Java version, AEM does not start up | AEM in case you are facing similar issue.

Avatar

Avatar
Validate 1
Level 2
nikhilgupta86
Level 2

Likes

2 likes

Total Posts

12 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
nikhilgupta86
Level 2

Likes

2 likes

Total Posts

12 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile
nikhilgupta86
Level 2

15-04-2019

Try Removing the following line from crx-quickstart/conf/sling.properties:

org.osgi.framework.system.capabilities=${eecap-${java.specification.version}}

and start AEM it should work, worked for me.

Avatar

Avatar
Level 1
hemanthm9258359
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
hemanthm9258359
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
hemanthm9258359
Level 1

16-04-2019

I updated to java version "1.8.0_151". I am using AEM6.3.

Try Removing the following line from crx-quickstart/conf/sling.properties:

org.osgi.framework.system.capabilities=${eecap-${java.specification.version}}

i TRIED CHECKING THIS. no such line exist. Thank you.

Avatar

Avatar
Give back 300
MVP
Gaurav-Behl
MVP

Likes

243 likes

Total Posts

1,145 posts

Correct Reply

281 solutions
Top badges earned
Give back 300
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile

Avatar
Give back 300
MVP
Gaurav-Behl
MVP

Likes

243 likes

Total Posts

1,145 posts

Correct Reply

281 solutions
Top badges earned
Give back 300
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile
Gaurav-Behl
MVP

16-04-2019

Could you share the error.log and stderr.log snippets?

Avatar

Avatar
Validate 1
Level 7
Prince_Shivhare
Level 7

Likes

97 likes

Total Posts

378 posts

Correct Reply

61 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 50
View profile

Avatar
Validate 1
Level 7
Prince_Shivhare
Level 7

Likes

97 likes

Total Posts

378 posts

Correct Reply

61 solutions
Top badges earned
Validate 1
Ignite 5
Ignite 3
Ignite 1
Give Back 50
View profile
Prince_Shivhare
Level 7

16-04-2019

could you please explain not working means?

are you able to see system/console/bundles ? or other consoles in aem?

Avatar

Avatar
Level 1
hemanthm9258359
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
hemanthm9258359
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
hemanthm9258359
Level 1

17-04-2019

I cannot see any console.

Avatar

Avatar
Level 1
hemanthm9258359
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
hemanthm9258359
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
hemanthm9258359
Level 1

17-04-2019

Low-memory action set to fork

Using 64bit VM settings, min.heap=1024MB, min permgen=256MB, default fork arguments=[-Xmx1024m, -XX:MaxPermSize=256m]

The JVM reports a heap size of 1024 MB, meets our expectation of 1024 MB +/- 20

No console, will fork to get enough memory

Not forking JVM as -nofork option is set

Setting properties from filename 'C:/Users/Hemanth/Desktop/AEM6.3-20180223T145720Z-001/AEM6.3/aem6.3-author-p4702.jar'

Option '-quickstart.server.port' set to '4702' from filename aem6.3-author-p4702.jar

Verbose option not active, closing stdin and redirecting stdout and stderr

Redirecting stdout to C:\Users\Hemanth\Desktop\AEM6.3-20180223T145720Z-001\AEM6.3\crx-quickstart\logs\stdout.log

Redirecting stderr to C:\Users\Hemanth\Desktop\AEM6.3-20180223T145720Z-001\AEM6.3\crx-quickstart\logs\stderr.log

ResourceProvider paths=[/gui, /gui/default]

loadProperties: found /gui/default/gui.properties

loadProperties: found /gui/gui.properties

getResourceURL: found /gui/cq55icon_round_WIN_512x512.gif

getResourceURL: found /gui/cq55icon_round_WIN_256x256.gif

getResourceURL: found /gui/cq55icon_round_WIN_128x128.gif

getResourceURL: found /gui/cq55icon_round_WIN_64x64.gif

getResourceURL: found /gui/cq55icon_round_WIN_48x48.gif

getResourceURL: found /gui/cq55icon_round_WIN_32x32.gif

getResourceURL: found /gui/cq55icon_round_WIN_16x16_block.gif

getResourceURL: found /gui/gui_bg_start.png

getResourceURL: found /gui/gui_bg_on_blank.png

getResourceURL: found /gui/gui_bg_off.png

org.osgi.framework.BundleException: Exported package names cannot be zero length.

at org.apache.felix.framework.util.manifestparser.ManifestParser.normalizeExportClauses(ManifestParser.java:898)

at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:216)

at org.apache.felix.framework.ExtensionManager.<init>(ExtensionManager.java:250)

at org.apache.felix.framework.Felix.<init>(Felix.java:429)

Avatar

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

186 likes

Total Posts

236 posts

Correct Reply

72 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile

Avatar
Establish
MVP
Ravi_Pampana
MVP

Likes

186 likes

Total Posts

236 posts

Correct Reply

72 solutions
Top badges earned
Establish
Contributor
Shape 1
Ignite 5
Ignite 3
View profile
Ravi_Pampana
MVP

17-04-2019

It seems to be memory issue, try increasing memory and test. Check below post

trying to install CQ author instance ?

Also check whether system has sufficient free space

Avatar

Avatar
Give back 300
MVP
Gaurav-Behl
MVP

Likes

243 likes

Total Posts

1,145 posts

Correct Reply

281 solutions
Top badges earned
Give back 300
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile

Avatar
Give back 300
MVP
Gaurav-Behl
MVP

Likes

243 likes

Total Posts

1,145 posts

Correct Reply

281 solutions
Top badges earned
Give back 300
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile
Gaurav-Behl
MVP

17-04-2019

As Ravi mentioned above, allocate more RAM when starting up AEM. If you're using Mac, use top to check RAM used by AEM and assign more using -Xmx2048m or 4096m