Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM components and layoout not visible in editor

Shivam_S
Level 2
Level 2

I installed a new AEM local instance AEM_6.5_Quickstart.jar. I started following wknd tutorial and created a project using maven archetype command given in project setup page of tutorial. I was able to create and install the project on my local instance however when i create first page as in tutorial and click on edit i dont see any layout container or components available in side rail. 

Shivam_S_0-1620079000767.png

 

Tried to check the template but same issue there as well 

Shivam_S_1-1620079041826.png

This is what i see in the console some dependencies are causing this issue?

Shivam_S_2-1620079095994.png

Please help i am unable to progress with the tutorial. Was facing below two challenges as well in other system

1st -java - AEM jar not starting - Stack Overflow

  2 -java - Unable to drag drop components on AEM new page - Stack Overflow 

 

1 Accepted Solution
Vijayalakshmi_S
Correct answer by
Community Advisor
Community Advisor

Hi @Shivam_S,

I suggest to check the Technical Requirements page for AEM. In particular, JVMhttps://experienceleague.adobe.com/docs/experience-manager-65/deploying/introduction/technical-requi...

Considering this, bring the AEM instance up with all bundles active in http://localhost:4502/system/console/bundles

+ no errors in error.log file ->  try accessing we-retail (sample content) site pages and can also try creating sample page within we-retail to test components (drag and drop)

If you have no issues so far, then work on WKND project - You can checkout the source code from this GitHub location - https://github.com/adobe/aem-guides-wknd -> Build/Install in your local. (As you are dealing with few other related issues, I suggest to resolve that and then work on WKND project)

View solution in original post

0 Replies
Pawan_Gupta_
Community Advisor
Community Advisor

couple of thing to be done initially

 

1. in osgi console check list of installed bundles (not started and not fragments) and try to start them based on IDs assigned

2. monitor the error.log for error while starting the bundle first and then will rendering the page. it will give you clue about what's happening

3. check the project package from /crx/packmgr/index.jsp and reinstall it again

4. restart the server again and check for the log for any error

(if still issue, fresh install rather debugging)

 

Shivam_S
Level 2
Level 2

@Pawan_Gupta_ 

I tried to stop the local instance and delete the crx-quickstart and restart..i create the project and install it again and every time i ge the same problem no components and no layout container. I checked the log when i click on edit after selecting a page and this is the error i could see.

 

04.05.2021 03:53:29.413 *WARN* [0:0:0:0:0:0:0:1 [1620080609229] GET /editor.html/content/wknd/us/en.html HTTP/1.1] org.apache.sling.caconfig.resource.impl.def.DefaultConfigurationResourceResolvingStrategy Ignoring reference to /conf/wknd/settings from /conf/wknd/settings - Probably misconfigured as it ends with '/settings'
04.05.2021 03:53:29.424 *WARN* [0:0:0:0:0:0:0:1 [1620080609229] GET /editor.html/content/wknd/us/en.html HTTP/1.1] org.apache.sling.caconfig.resource.impl.def.DefaultConfigurationResourceResolvingStrategy Ignoring reference to /conf/wknd/settings from /conf/wknd/settings - Probably misconfigured as it ends with '/settings'

04.05.2021 03:53:29.653 *ERROR* [0:0:0:0:0:0:0:1 [1620080609628] GET /content/wknd/us/en.html HTTP/1.1] org.apache.sling.servlets.get.impl.DefaultGetServlet No renderer for extension html, cannot render resource JcrNodeResource, type=wknd/components/container, superType=null, path=/conf/wknd/settings/wcm/templates/page-content/structure/jcr:content/root

 

package manager shows the installed packages for wknd project all,content,config,apps. Tried restarting the jar and these are the only warnings i could see in error.log and no errors were present for restart.

 

04.05.2021 04:03:27.807 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/social/commons/components/hbs/comments/clientlibs specified dependencies that could not be resolved: cq.social.mention
04.05.2021 04:03:27.808 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /apps/wknd/clientlibs/clientlib-base specified embedded that could not be resolved: core.wcm.components.commons.datalayer.v1,core.wcm.components.pdfviewer.v1,core.wcm.components.accordion.v1
04.05.2021 04:03:27.808 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/social/commons/components/hbs/featuredcontent/clientlibs specified dependencies that could not be resolved: cq.social.author.commons.hbs.featuredtopic
04.05.2021 04:03:27.811 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/cq/gui/components/authoring/editors/clientlibs/sites/page specified embedded that could not be resolved: cq.authoring.editor.plugin.mobile,cq.authoring.editor.plugin.dps,cq.authoring.editor.plugin.manuscript
04.05.2021 04:03:27.811 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/cq/gui/components/authoring/editors/clientlibs/sites/template specified embedded that could not be resolved: cq.authoring.editor.sites.template.hook
04.05.2021 04:03:27.813 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/fd/expeditor/clientlibs/main specified dependencies that could not be resolved: aem.fdm.services
04.05.2021 04:03:27.814 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/dam/gui/components/admin/idsprint/templates/addtemplatewizardpage/clientlibs/addtemplate specified dependencies that could not be resolved: granite.ui.coral.formbuilder,granite.ui.coral.notifications
04.05.2021 04:03:27.814 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/dam/gui/components/admin/idsprint/templates/edittemplatewizardpage/clientlibs/editbrochure specified dependencies that could not be resolved: granite.ui.coral.formbuilder,granite.ui.coral.notifications
04.05.2021 04:03:27.814 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/dam/gui/components/admin/idsprint/templates/mergetemplate/brochureassemble specified dependencies that could not be resolved: granite.ui.coral.formbuilder,granite.ui.coral.notifications
04.05.2021 04:03:27.814 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/dam/gui/components/s7dam/common/crop/smartcrop specified dependencies that could not be resolved: granite.ui.coral.foundation.admin
04.05.2021 04:03:27.814 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/dam/gui/components/s7dam/shoppablevideo/clientlibs/shoppablevideo specified dependencies that could not be resolved: granite.ui.coral.foundation.admin
04.05.2021 04:03:27.814 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/dam/gui/components/s7dam/smartcropedit/clientlibs/smartcropcard specified dependencies that could not be resolved: granite.ui.coral.foundation.admin
04.05.2021 04:03:27.814 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/dam/gui/components/s7dam/smartcropedit/clientlibs/smartcropedit specified dependencies that could not be resolved: granite.ui.coral.foundation.admin
04.05.2021 04:03:27.816 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/fd/af/authoring/editors/clientlibs/form specified embedded that could not be resolved: cq.authoring.editor.plugin.mobile,cq.authoring.editor.plugin.dps,cq.authoring.editor.plugin.manuscript
04.05.2021 04:03:27.816 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/fd/af/authoring/editors/clientlibs/template specified dependencies that could not be resolved: cq.authoring.editor.sites.template.hook
04.05.2021 04:03:27.818 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/screens/dcc/components/clientlibs specified dependencies that could not be resolved: cq.screens.dcc.validation
04.05.2021 04:03:27.818 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] com.adobe.granite.ui.clientlibs.impl.LibraryCacheImpl Library /libs/social/enablement/components/clientlibs/assets specified embedded that could not be resolved: dam.search.smartcollection.infopanel,dam.search.samrtcollection.toolbar.dialogs,dam.admin.search.predicates
04.05.2021 04:03:27.992 *WARN* [0:0:0:0:0:0:0:1 [1620081205595] GET /aem/start.html HTTP/1.1] org.apache.sling.commons.compiler.impl.EclipseJavaCompiler Using unsupported java version '11', assuming latest supported version '9'

 

SureshDhulipudi
Community Advisor
Community Advisor

Please find the dependencies in your pom.xml

1- what version of wknd tutorial you are installing

2- Go to your http://localhost:4502/system/console/depfinder

and enter the org.apache.sling.api.resource and click on Find

 

Package version should match to the entry in your pom.xml

 

<dependency>

<artifactId>org.apache.sling.api</artifactId>

<version>2.22.0</version>

<groupId>org.apache.sling</groupId>

<scope>provided</scope>

</dependency>

 

Shivam_S
Level 2
Level 2

Hello @SureshDhulipudi  i am installing from this link: https://github.com/adobe/aem-guides-wknd.

I checked the dependency for the org.apache.sling.api.resource and found the version as 

Shivam_S_0-1620137482001.png

When i search in parent pom.xml there is no such dependency present 

Shivam_S_1-1620137563898.png

 

Vijayalakshmi_S
Correct answer by
Community Advisor
Community Advisor

Hi @Shivam_S,

I suggest to check the Technical Requirements page for AEM. In particular, JVMhttps://experienceleague.adobe.com/docs/experience-manager-65/deploying/introduction/technical-requi...

Considering this, bring the AEM instance up with all bundles active in http://localhost:4502/system/console/bundles

+ no errors in error.log file ->  try accessing we-retail (sample content) site pages and can also try creating sample page within we-retail to test components (drag and drop)

If you have no issues so far, then work on WKND project - You can checkout the source code from this GitHub location - https://github.com/adobe/aem-guides-wknd -> Build/Install in your local. (As you are dealing with few other related issues, I suggest to resolve that and then work on WKND project)

View solution in original post

Shivam_S
Level 2
Level 2

Hi @Vijayalakshmi_S I am able to edit/drag drop components on we.retail site without any issues. I just read in the description of github repo you shared and tried the maven command with option -Pclassic for AEM 6.x.x version and that seems to have fixed the problem now.

 

Shivam_S_0-1620137984630.png