Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM cloud - extended carousel & image components are not working

Avatar

Level 3

Hi Team,

could someone suggest me on the below issue please.

1. Extended core components carousel & image

2. Added few new fields in the dialog in both the extended components, no changes in html.

3. authored carousel inside with the image components

4. Issue: it was showing any two images on the page.

5. but there is no issue in publish mode & local environment. Issue persists only on dev & stage environments.

Note: It was working properly after renamed the image component to imagev2 or with any other name with the same code. The name image only not working.

Issue:

Lakshmi9_0-1658485959441.png

 

Showing any two images randomly.

Lakshmi9_1-1658486192477.png

 

 

Thank you in advance!!

4 Replies

Avatar

Level 7

@Lakshmi9 Please check if the core pakages are matching between environments.

you can check this in package manager - 

core.wcm.components.content-x.x.x.zip

Avatar

Level 3

@ManuMathew1994 

verified but didn't find any discrepancies. Any other suggestions please?

 

Thank you

Avatar

Level 3

Hi @ManuMathew1994 , please find the screenshots below. Kindly let me know if anything is required. And the imageupdated(copy of the image component & renamed) is working as expected in the carousel.

Image component

Lakshmi9_0-1658841702825.png

Carousel component

Lakshmi9_1-1658841811507.png

Thank you