AEM Cannot be resolved for some libs

Avatar

Avatar

vasim_akram_sha

Avatar

vasim_akram_sha

vasim_akram_sha

01-03-2016

Hi,

    I am using AEM 5.6.1. I am getting following error.

        org.apache.sling.api,version=[2.3,3) -- Cannot be resolved
        org.apache.sling.api.request,version=[2.4,3) -- Cannot be resolved
        org.apache.sling.api.resource,version=[2.5,3) -- Cannot be resolved
        org.apache.sling.models.annotations,version=[1.0,2) -- Cannot be resolved
        org.apache.sling.settings,version=[1.3,2) -- Cannot be resolved.

 

In /system/console/depfinder I found org.apache.sling.api depencies as 

<dependency>
    <groupId>org.apache.sling</groupId>
    <artifactId>org.apache.sling.api</artifactId>
    <version>2.4.3-R1488084</version>
    <scope>provided</scope>
</dependency>

In pom.xml file I mentioned same dependencies. Still I am getting same issue.  

Replies

Avatar

Avatar

edubey

Avatar

edubey

edubey

01-03-2016

Are you facing issue when you deploy your project or when you open any default give project.

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

01-03-2016

We have a community article that shows you how to succcessfully use SLing APIs in 5.x. I think your issue is your POM dependencies. See this article: 

Using Sling APIs to retrieve content from the Adobe Experience Manager Repository

Hope this helps

Avatar

Avatar

vandanasharma

Avatar

vandanasharma

vandanasharma

16-05-2020

Hi,

 

I am getting error - org.apache.sling.event.jobs,version=[1.5,2] -- Cannot be resolved

ERROR* [FelixDispatchQueue] IA_Wrapper_Services.core FrameworkEvent ERROR (org.osgi.framework.BundleException: Unable to resolve IA_Wrapper_Services.core [582](R 582.0): missing requirement [IA_Wrapper_Services.core [582](R 582.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.event.jobs)(version>=1.5.0)(version<=2.0.0)) Unresolved requirements: [[IA_Wrapper_Services.core [582](R 582.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.event.jobs)(version>=1.5.0)(version<=2.0.0))])
org.osgi.framework.BundleException: Unable to resolve IA_Wrapper_Services.core [582](R 582.0): missing requirement [IA_Wrapper_Services.core [582](R 582.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.event.jobs)(version>=1.5.0)(version<=2.0.0)) Unresolved requirements: [[IA_Wrapper_Services.core [582](R 582.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.event.jobs)(version>=1.5.0)(version<=2.0.0))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Unknown Source)

 

Please reply