Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM 6.5 on premise File Upload stopped working

Leena_1
Level 4
Level 4

Hi,

The uploading of file stopped working. When trying to upload an XDP template, the clicking of the 'File Upload' opens the directory to select a file, but after clicking on the file the directory closes but the .xdp form is not uploaded to server:port//aem/forms.html/content/dam/formsanddocuments/

FileUploadNotWorking.PNG

What could have happened to cause this? I restarted the server this morning after adding the path to fonts in CQ-DAM-Handler-Gibson Font Manager Service.

Thanks,

Leena

4 Replies
PulkitJain
Employee
Employee

@Leena_1  This seems to be an issue specific to your AEM instance.

Is the instance in a good state, bundles are in active state? Is this issue browser specific?

Please review the console logs for any specific errors or network logs.

Leena_1
Level 4
Level 4

Hi Pulkit,

Thanks for the quick response. It happens in other browsers too, and all the bundles are active. 

In the error.log it shows Resource /libs/fd/fm/gui/content/forms.html/content/dam/formsanddocuments not found. And loading 0 entries for 'en_US' (basename: <none>). What could be the reason? I added the path to fonts in CQ-DAM-Handler-Gibson Font Manager Service this morning. To fix this issue, I tried to undo the paths that  was added for the fonts in CQ-DAM-Handler-Gibson Font Manager Service and restarted the AEM instance. This did not fix it, so I put back the path to the fonts again and restarted the instance. 

15.11.2021 14:38:59.972 *INFO* [sling-cq-polling-importer-4-myDataSource] com.day.cq.polling.importer.impl.PollingImporterImpl importData: Importing data from livefyreRightsImporter:myDataSource to /etc/importers/polling/livefyre-poller/jcr:content as polling-importer-service by com.adobe.social.integrations.livefyre.livefyreAssetImporter.impl.LivefyreRightsRequestPoller@2afeebe8
15.11.2021 14:39:13.525 *INFO* [10.3.248.58 [1637005153504] GET /aem/forms.html/content/dam/formsanddocuments/testpublicforms HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Resource /libs/fd/fm/gui/content/forms.html/content/dam/formsanddocuments not found
15.11.2021 14:39:13.607 *INFO* [10.3.248.58 [1637005153582] GET /libs/granite/core/content/login.html HTTP/1.1] org.apache.sling.i18n.impl.JcrResourceBundle Finding all dictionaries for 'en_US' (basename: <none>) ...
15.11.2021 14:39:13.639 *INFO* [10.3.248.58 [1637005153582] GET /libs/granite/core/content/login.html HTTP/1.1] org.apache.sling.i18n.impl.JcrResourceBundle Finished loading 0 entries for 'en_US' (basename: <none>) in 32ms
15.11.2021 14:39:13.641 *INFO* [10.3.248.58 [1637005153582] GET /libs/granite/core/content/login.html HTTP/1.1] org.apache.sling.i18n Service [8516, [java.util.ResourceBundle]] ServiceEvent REGISTERED
15.11.2021 14:39:13.645 *INFO* [10.3.248.58 [1637005153582] GET /libs/granite/core/content/login.html HTTP/1.1] org.apache.sling.i18n.impl.JcrResourceBundleProvider Currently loaded dictionaries across all locales: [/libs/cq/searchpromote/components/pagination/i18n/en, /libs/social/subscriptions/components/hbs/subscriptions/i18n/en, /libs/foundation/components/search/i18n/en, /libs/foundation/components/mobilefooter/i18n/en, /libs/commerce/components/search/i18n/en, /libs/social/commons/components/hbs/comments/i18n/en]
15.11.2021 14:39:13.648 *WARN* [10.3.248.58 [1637005153582] GET /libs/granite/core/content/login.html HTTP/1.1] libs.granite.core.components.login.login$jsp j_reason param value 'unknown' cannot be mapped to a valid reason message: ignoring
15.11.2021 14:39:20.639 *INFO* [Apache Sling Resource Resolver Finalizer Thread] com.adobe.granite.repository Service [8512, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent UNREGISTERING
15.11.2021 14:39:20.651 *INFO* [Apache Sling Resource Resolver Finalizer Thread] com.adobe.granite.repository Service [8515, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent UNREGISTERING
15.11.2021 14:39:20.661 *INFO* [Apache Sling Resource Resolver Finalizer Thread] com.adobe.granite.repository Service [8513, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent UNREGISTERING
15.11.2021 14:39:20.668 *INFO* [Apache Sling Resource Resolver Finalizer Thread] com.adobe.granite.repository Service [8511, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent UNREGISTERING
15.11.2021 14:39:20.678 *INFO* [Apache Sling Resource Resolver Finalizer Thread] com.adobe.granite.repository Service [8514, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent UNREGISTERING
15.11.2021 14:39:50.408 *INFO* [sling-default-5-health-org.apache.sling.discovery.oak.SynchronizedClocksHealthCheck] org.apache.sling.discovery.oak.SynchronizedClocksHealthCheck execute: no topology connectors connected to local instance.
15.11.2021 14:39:59.978 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [8517, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED
15.11.2021 14:39:59.983 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [8518, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED
15.11.2021 14:39:59.986 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [8519, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED
15.11.2021 14:39:59.990 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [8520, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED
15.11.2021 14:39:59.994 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [8521, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED
15.11.2021 14:40:27.891 *ERROR* [qtp1354400680-1745] org.apache.felix.metatype Missing element AD in element OCD :

Thanks,

Leena

 

PulkitJain
Employee
Employee

@Leena_1 

If reverting the changes is not helping then this might not be the cause of the issue.

Please reinstall the AEM Forms package (do recheck the correct version[0]) and capture the HAR logs in case the issue persists. 

 

 

[0] - https://experienceleague.adobe.com/docs/experience-manager-release-information/aem-release-updates/f... 

Leena_1
Level 4
Level 4

Hi Pulkit,

Is there a way to resolve it without reinstalling the AEM forms package, since I do not have that option. What could be the reason for the following error.log entry:

16.11.2021 00:26:09.985 *INFO* [10.3.223.10 [1637040369985] HEAD /aem/forms.html/content/dam/formsanddocuments/testpublicforms HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Resource /libs/fd/fm/gui/content/forms.html/content/dam/formsanddocuments/testpublicforms not found
16.11.2021 00:26:09.985 *INFO* [sling-default-1-com.day.cq.rewriter.linkchecker.impl.LinkCheckerTask.3327] com.day.cq.rewriter.linkchecker.impl.LinkCheckerTask Checked URL http://bos-aem01:6754/aem/forms.html/content/dam/formsanddocuments/testpublicforms: 404 (invalid)

There are 3 sub folders within the formsanddocuments folder. 

I have opened an Adobe Support ticket - E-000502851.

Thanks,

Leena

PulkitJain
Employee
Employee

@Leena_1 

Let's discuss this issue today over a screenshare. I will share the meeting invite over the support ticket.