Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM 6.5.11 guideContainer.submit.jsp returns 404

Avatar

Level 2

Hello, I've just upgraded from AEM 6.3 to 6.5.11 and am seeing an issue with our forms. Currently when submitting any of our forms I am seeing an initial success call from /jcr:content/guideContainer.af.internalsubmit.jsp but afterwards when it tries to call /jcr:content/guideContainer.af.submit.jsp, it returns a 404 with no visible error entries in the error.log. Can anyone help me figure out why this might be happening?

 

I've only been able to find one other question/answer to similar to this (https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/form-is-not-getting-submit...), but that involves updates to dispatcher which we currently do not use as we use a 3rd party CDN provider.

 

My initial thought was a namespace mangling issue but it was noted that this is enabled by default so the jcr:content bit may not be the issue here. Any responses is greatly apprecieated

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi All, The issue i've initially noted above has been resolved. Apparently the AEM Forms 6.5.11.0 package breaks the 'Send mail' submit action on forms, as noted here: https://experienceleague.adobe.com/docs/experience-manager-65/release-notes/release-notes.html?lang=... (see the small disclaimer (below) titled "Issues fixed in AEM Forms 6.5.11"):

Screen Shot 2022-02-04 at 4.13.28 PM.png

After installing the AEM Forms 6.5.11.1 for Linux package on our instance, the forms now submit properly. Hopefully this helps anyone else facing this same issue. Cheers!

View solution in original post

1 Reply

Avatar

Level 2

I might be on the right path but I'm noticing that our client devs added a folder location at: /apps/[client  name]/custom_submit_actions/[form_name]. The main file in these folders is named post.POST.jsp which I assume are custom post actions to use in place of the default post action for a guideContainer.

 

When looking at the forms under at node /content/forms/[client_name]/[form_name]/jcr:content/guideContainer, the interesting thing I'm seeing is the actionType property is set as fd/af/components/guidesubmittype/email but when I update it to used the custom post actions mentioned earlier, the form will submit properly.

 

The other interesting thing is that the 'actionType' is set to fd/af/components/guidesubmittype/email on the older AEM 6.3 instance on these same forms and submit fine on the older AEM version.

Avatar

Level 2

Another finding is that if I remove 'actionType', the form submits properly, but I don't know if this is the best way to solve the issue.

Avatar

Correct answer by
Level 2

Hi All, The issue i've initially noted above has been resolved. Apparently the AEM Forms 6.5.11.0 package breaks the 'Send mail' submit action on forms, as noted here: https://experienceleague.adobe.com/docs/experience-manager-65/release-notes/release-notes.html?lang=... (see the small disclaimer (below) titled "Issues fixed in AEM Forms 6.5.11"):

Screen Shot 2022-02-04 at 4.13.28 PM.png

After installing the AEM Forms 6.5.11.1 for Linux package on our instance, the forms now submit properly. Hopefully this helps anyone else facing this same issue. Cheers!