Highlighted

AEM 6.4 sp2 cq:actions doesn't work with editannotatecopymovedeleteinsert

Avatar

Avatar

henriquer230337

Avatar

henriquer230337

henriquer230337

07-11-2018

We installed sp2 in our 6.4 instance,

and some issues were found.

When using cq:actions editannotatecopymovedeleteinsert, the edit toolbar options aren't clickable like it was on aem 6.4.

Example (classic ui view)

Screenshot from 2018-11-07 16-27-50.png

The options in uppercase doesn't work

Separating by comma using:

editannotate,copymove,delete,insert

The edit and annotate stays as in the print above while the rest works ok.

Anyone also had the same issue? Or has some suggestion?

We don't have the intention of migrating to touch ui as of now.

Thanks

Replies

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

07-11-2018

If this worked before and not know - it could be a bug.

Avatar

Avatar

Ravi_Pampana

MVP

Avatar

Ravi_Pampana

MVP

Ravi_Pampana
MVP

07-11-2018

Hi,

I tried in AEM 6.4 SP2 instance and I am able to click on Cut, Copy, Paste options in classic pages (cf#)

Screen Shot 2018-11-07 at 2.18.34 PM.png

Highlighted

Avatar

Avatar

henriquer230337

Avatar

henriquer230337

henriquer230337

08-11-2018

Hi ravip15579397 are you using the action config mentioned above? If possible can you share how it's specifically so I can see if there's any difference.

Also in the .content.xml file are you setting a sling:resourceType or sling:resourceSuperType?

Trying to get the difference in our configurations here.

smacdonald2008​ yes it was working on aem 6.4 but not on 6.4.2, from the release notes it looks like there shouldn't be a change in this functionality, but it was something we noticed after installing SP2.

Thanks for both responses

Highlighted

Avatar

Avatar

henriquer230337

Avatar

henriquer230337

henriquer230337

08-11-2018

Adding to the thread we saw that the package acs-aem-commons-3.17 column control component has the action configs of cq:actions="[text:Column Control,edit,annotate,delete]"

But on author view the annotate for it doesn't work too.

Screenshot from 2018-11-08 11-00-07.png

Highlighted

Avatar

Avatar

henriquer230337

Avatar

henriquer230337

henriquer230337

12-11-2018

Update regarding this issue.

We noticed on our html of author view, there are some scripts that calls CQ.WCM.edit() function.

We noticed a difference that is causing the issue in SP2 that is different from an environment without SP2.

This is the place that calls wcm.edit without sp2:

CQ.WCM.edit({"path":"/content/test/en/users/ea2/henrique/test-annotate/jcr:content/common_content_iparsys/editprofile","dialog":"/apps/janrainna/components/modal/EditProfile/dialog","type":"janrainna/components/modal/EditProfile","csp":"MainTemplate|SiteRoot|page|basicpage/common_content_iparsys|iparsys|parsys/EditProfile|parbase","editConfig":{"xtype":"editbar","listeners":{"afteredit":"REFRESH_PAGE","afterinsert":"REFRESH_PAGE"},"inlineEditing":CQ.wcm.EditBase.INLINE_MODE_NEVER,"actions":[{"xtype":"tbtext","text":"Edit Profile NA (Modal)"},{"xtype":"tbseparator"},CQ.wcm.EditBase.EDITANNOTATECOPYMOVEDELETEINSERT],"disableTargeting":true},"msm:liveRelationship":{"msm:syncPath":"/en/users/ea2/henrique/test-annotate/jcr:content/common_content_iparsys/editprofile","msm:sourcePath":"/content/coke-preview/en/users/ea2/henrique/test-annotate/jcr:content/common_content_iparsys/editprofile","msm:targetPath":"/content/test/en/users/ea2/henrique/test-annotate/jcr:content/common_content_iparsys/editprofile","msm:liveCopyPath":"/content/test","msm:liveCopyBpPath":"/content/test-preview","msm:isDeep":true,"msm:isInheritedConfig":true,"msm:isRootConfig":true,"msm:status":{"msm:isCancelled":false,"msm:isCancelledForChildren":false,"msm:isCancelledOn":"","msm:isEditable":true,"msm:isTargetExisting":true,"msm:isSourceExisting":false,"msm:isPage":false,"cq:lastRolledout":"","cq:lastRolledoutBy":"","msm:isSourceModified":false,"msm:isSourceDeleted":false,"msm:isTargetFromDifferentTree":false,"msm:isTargetSkipped":false,"msm:isTargetModified":false,"msm:isTargetDeleted":false,"msm:isTargetManuallyCreated":true,"msm:cancelledProperties":[]},"cq:rolloutConfigs":["/libs/msm/wcm/rolloutconfigs/default"],"msm:computationTime":-1}});

And this is with SP2

CQ.WCM.edit({"path":"/content/test/en/users/henrique/login-registration/jcr:content/pageContent/editprofile","dialog":"/apps/janrainna/components/modal/EditProfile/dialog","type":"janrainna/components/modal/EditProfile","csp":"MainTemplate|SiteRoot|page|basicpage/pageContent|parsys/EditProfile|parbase","editConfig":{"xtype":"editbar","listeners":{"afteredit":"REFRESH_PAGE","afterinsert":"REFRESH_PAGE"},"inlineEditing":"CQ.wcm.EditBase.INLINE_MODE_NEVER","actions":[{"xtype":"tbtext","text":"Edit Profile NA (Modal)"},{"xtype":"tbseparator"},"CQ.wcm.EditBase.EDITANNOTATECOPYMOVEDELETEINSERT"],"disableTargeting":true}});

There're some differences regarding the page being a livecopy, path etc... but those shouldn't matter for this issue.

The main factor we noticed is the actions property.

Which without SP2 is

actions":[{"xtype":"tbtext","text":"Edit Profile NA (Modal)"},{"xtype":"tbseparator"},CQ.wcm.EditBase.EDITANNOTATECOPYMOVEDELETEINSERT]

and with SP2 it's

"actions":[{"xtype":"tbtext","text":"Edit Profile NA (Modal)"},{"xtype":"tbseparator"},"CQ.wcm.EditBase.EDITANNOTATECOPYMOVEDELETEINSERT"]

It's noticed that with SP2 instead of pointing to the const CQ.wcm.EditBase.EDITANNOTATECOPYMOVEDELETEINSERT

it's passing a String "CQ.wcm.EditBase.EDITANNOTATECOPYMOVEDELETEINSERT" foward thus causing the issue in the js when it tries to check the actions on applyConfigDefaults: function(config, defaults)

Highlighted

Avatar

Avatar

henriquer230337

Avatar

henriquer230337

henriquer230337

21-11-2018

Just updating this thread.

A daycare was open and from adobe reply it's a bug in sp2.

There's no hotfix yet, if we receive any update regarding it we'll update this thread too.

Thanks

Highlighted

Avatar

Avatar

arsalankhan

Avatar

arsalankhan

arsalankhan

16-01-2019

we are also facing the same issue.  Edit and Annotate in the Editbar are not clickable. Has it been fixed in 6.4 SP3 ?

Highlighted

Avatar

Avatar

евгенийс6214351

Avatar

евгенийс6214351

евгенийс6214351

17-01-2019

Hi, did you find the solution to fix? If yes could you assist me please, I have the same issue. It is reproducible on SP3

Highlighted

Avatar

Avatar

arsalankhan

Avatar

arsalankhan

arsalankhan

18-01-2019

I did not find the solution yet. Would be happy to have some pointers to solve the issue.