Expand my Community achievements bar.

Dive into Adobe Summit 2024! Explore curated list of AEM sessions & labs, register, connect with experts, ask questions, engage, and share insights. Don't miss the excitement.
SOLVED

AEM 6.3 xhr requests and 404 error

Avatar

Level 4

I have installed AEM 6.3 in local and deployed the application build on 6.1.

I see following kind of requests for every page that requested and these requests resulting in 404 error.

http://localhost:6302/resource-status/editor/en_US/rewards/profile-and-preferences.1.json?_=1507845945859

Question: why 6.3 making these xhr requests ? I am sure these requests are failing as there is no node called "resource-status" at root level.

Thanks,

Sreeni

1 Accepted Solution

Avatar

Correct answer by
Level 10

Hi,

AEM 6.3 has introduced resource editor APIs [0] which can be consumed to basically check the status and notify the author in editor mode.

Those are causing XHR request

[0] Adobe Experience Manager Help | Developing Resource Statuses in AEM Sites

Thanks

View solution in original post

5 Replies

Avatar

Level 10

You should rebuild your AEM app using AEM 6.3 APIs, including Uber 6.3.

Avatar

Level 4

Yes application pom is referring to Uber 6.3

The above mentioned 404 requests are happening when url has "editor.html" / editor mode

In preview mode, everything looks fine and no 404 errors.

Avatar

Correct answer by
Level 10

Hi,

AEM 6.3 has introduced resource editor APIs [0] which can be consumed to basically check the status and notify the author in editor mode.

Those are causing XHR request

[0] Adobe Experience Manager Help | Developing Resource Statuses in AEM Sites

Thanks

Avatar

Level 2

I am having the same issue after upgrading . without editor.html in the URL it works fine where as with editor.html , its throwing 404 page.

can you please let me know how did you resolve this ?