Highlighted

AEM 6.1-6.3 upgrade - Replication Agents Disabled Failed.

test10909090

05-02-2018

Hi,

We are trying to upgrade from AEM 6.1 SP1 to 6.3. On running pre-upgrade steps, getting following error:

areAllPreUpgradeHealthChecksOK=false

Maintenance\ Task\ WorkflowPurgeTask=OK

Maintenance\ Task\ RevisionCleanupTask=OK

Modified\ Deprecated\ Indexes=OK

Maintenance\ Task\ com.day.cq.audit.impl.AuditLogMaintenanceTask=OK

Replication\ Agents\ Disabled=HEALTH_CHECK_ERROR

We have disabled all the replication agents, still getting error that Replication Agents Disabled failed.

Ran following pre-upgrade health checks:

Maintenance Task com.day.cq.audit.impl.AuditLogMaintenanceTask successful

Maintenance Task RevisionCleanupTask successful

Maintenance Task WorkflowPurgeTask successful

Replication Agents Disabled failed!

Modified Deprecated Indexes successful

Anyone seen this error before?

Thanks!

Replies

Highlighted

kautuk_sahni

Community Manager

06-02-2018

6.3 includes pre-upgrade checks that need to pass for the upgrade to complete successfully.

You need to disable all the replication agents on your system and make sure the audit log maintenance is configured correctly (“Audit Log Purge Scheduler” in configMgr) so it could be executed pre-upgrade.

-Kautuk

Highlighted

test10909090

08-02-2018

Thanks Kautuk. We already disabled all the replication agents. All the other pre-upgrade checks are successful including audit log purge scheduler.

We still keep on getting Replication agents disabled error.

Ran following pre-upgrade health checks:

Maintenance Task com.day.cq.audit.impl.AuditLogMaintenanceTask successful

Maintenance Task RevisionCleanupTask successful

Maintenance Task WorkflowPurgeTask successful

Replication Agents Disabled failed!

Modified Deprecated Indexes successful

Highlighted

test10909090

08-02-2018

No, all we see in error.log is below: We have verified using CRXDE as well that all the replication agents are disabled.

05.02.2018 09:45:40.444 *INFO* [qtp863875948-895] com.adobe.aem.upgrade.precheck s.mbean.impl.PreUpgradeTasksMBeanImpl Started running all pre-upgrade health che cks.

05.02.2018 09:45:40.505 *INFO* [qtp863875948-895] com.adobe.aem.upgrade.precheck s.mbean.impl.PreUpgradeTasksMBeanImpl Maintenance Task com.day.cq.audit.impl.Aud itLogMaintenanceTask ran successfully.

05.02.2018 09:45:40.505 *INFO* [qtp863875948-895] com.adobe.aem.upgrade.precheck s.mbean.impl.PreUpgradeTasksMBeanImpl Maintenance Task RevisionCleanupTask ran s uccessfully.

05.02.2018 09:45:40.505 *INFO* [qtp863875948-895] com.adobe.aem.upgrade.precheck s.mbean.impl.PreUpgradeTasksMBeanImpl Maintenance Task WorkflowPurgeTask ran suc cessfully.

05.02.2018 09:45:40.573 *ERROR* [qtp863875948-895] com.adobe.aem.upgrade.prechec ks.mbean.impl.PreUpgradeTasksMBeanImpl Replication Agents Disabled failed!

Highlighted

test10909090

13-02-2018

We were able to resolve the issue, it turned out there was a OTB replication agent from 5.6.1 that migrated to 6.1, and was not showing in the Tools-> Replication UI.

We disabled it using the CRXDE and re-ran the pre-upgrade health check.

Thanks