Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

6.2 unresolved bundles

Avatar

Level 2

Hi,

I've just installed AEM 6.2 in our environment and installed an AEM 6.1 package on it. I using the Uber APIs but the following can't resolve :

com.day.cq.commons,version=[6.0,7) -- Cannot be resolved
com.day.cq.commons.date,version=[5.7,6) -- Cannot be resolved
com.day.cq.commons.inherit,version=[5.7,6) -- Cannot be resolved
com.day.cq.commons.jcr,version=[6.0,7) -- Cannot be resolved
com.day.cq.commons.mail,version=[5.7,6) -- Cannot be resolved

Any idea on how to resolve these?

lebom

3 Replies

Avatar

Community Advisor

Hi ,
 

Please let us know which dependency you added in POM file.

 

~ Prince Shivhare

Avatar

Level 10

Rebuild your OSGi using Maven 10 Archetype and Urber 6,2 -- see: 

https://helpx.adobe.com/experience-manager/using/first-arch10.html

Notice the use of Urber 6.2 in the POM file. 

Avatar

Level 10

If you still get that error - use depen finder in AEM and get the correct version in AEM for this package, Make sure you specify that package in your POM. 

But the most important thing is to use the 6.2 Urber version in your POM file for AEM 6.2. 

Avatar

Level 2

The error I now get is : "Failed to execute goal org.apache.felix:maven-scr-plugin:1.17.0:scr (generate-scr-scrdescriptor) on project suninternational-main.core: Execution generate-scr-scrdescriptor of goal org.apache.felix:maven-scr-plugin:1.17.0:scr failed: An API incompatibility was encountered while executing org.apache.felix:maven-scr-plugin:1.17.0:scr: java.lang.VerifyError: Constructor must call super() or this() before return".

I have this in my POM files:

Parent

<dependency>
                <groupId>com.adobe.aem</groupId>
                <artifactId>uber-jar</artifactId>
                <version>6.2.0</version>
                <classifier>obfuscated-apis</classifier>
                <scope>provided</scope>

</dependency>

Core

<dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>uber-jar</artifactId>
            <classifier>obfuscated-apis</classifier>
        </dependency>

UI

<dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>uber-jar</artifactId>
            <classifier>obfuscated-apis</classifier>
        </dependency>

Avatar

Level 2

In our current 6.1 version, there is a bundle with the following details:

Day Communique 5 Commons Library com.day.cq.cq-commons
Symbolic Name    com.day.cq.cq-commons
Version    5.7.18
Bundle Location    fileinstallpatch:/cq-commons-5.7.14.jar
Last Modification    Thu May 21 20:35:39 SAST 2015
Bundle Documentation    http://www.adobe.com/
Vendor    Adobe Systems Incorporated
Description    Bundle implementing the common functionality for the Communique 5 platform
Start Level    20
Exported Packages    com.day.cq.commons,version=5.7.0
com.day.cq.commons.date,version=5.7.0
com.day.cq.commons.feed,version=5.7.0
com.day.cq.commons.folderpreview,version=5.7.18
com.day.cq.commons.inherit,version=5.7.0
com.day.cq.commons.jcr,version=5.7.0
com.day.cq.commons.mail,version=5.7.0
com.day.cq.commons.predicate,version=5.7.0
com.day.cq.commons.servlets,version=5.7.0
com.day.cq.commons.thumbnail,version=5.7.0
Imported Packages    com.adobe.granite.license,version=1.1.0 from com.adobe.granite.license (44)
com.day.cq.i18n,version=5.4.0 from com.day.cq.cq-i18n (138)
com.day.cq.replication,version=5.16.0 from com.day.cq.cq-replication (151)

that resolves :

com.day.cq.commons,version=[6.0,7) -- Cannot be resolved
com.day.cq.commons.date,version=[5.7,6) -- Cannot be resolved
com.day.cq.commons.inherit,version=[5.7,6) -- Cannot be resolved
com.day.cq.commons.jcr,version=[6.0,7) -- Cannot be resolved
com.day.cq.commons.mail,version=[5.7,6) -- Cannot be resolved

but in 6.2 the bundle is not there. What bundle can I use in 6.2 to resolve the unresolvable packages above? 

Avatar

Community Advisor

Hi,

Please try to remove  <classifier>obfuscated-apis</classifier>.

and check again.

 

~ Prince

Avatar

Community Advisor

you can also try.

In the parent pom.xml:

<dependency>
                <groupId>com.adobe.aem</groupId>
                <artifactId>uber-jar</artifactId>
                <version>6.2.0-SP1</version>
                <scope>provided</scope>
                <classifier>apis</classifier>
            </dependency>

Core Pom file:
<dependency>
                  <groupId>com.adobe.aem</groupId>
                  <artifactId>uber-jar</artifactId>
                  <classifier>apis</classifier>
            </dependency>

UI Pom file:
<dependency>
                  <groupId>com.adobe.aem</groupId>
                  <artifactId>uber-jar</artifactId>
                  <classifier>apis</classifier>
            </dependency>

 

~ Prince

Avatar

Level 5

Prince Shivhare wrote...

you can also try.

In the parent pom.xml:

<dependency>
                <groupId>com.adobe.aem</groupId>
                <artifactId>uber-jar</artifactId>
                <version>6.2.0-SP1</version>
                <scope>provided</scope>
                <classifier>apis</classifier>
            </dependency>

 

Wouldn't they need to manually install the unobfuscated JARs into their local .m2 repo if they used this dependency?

Avatar

Community Advisor

Hey,

I tried it at my end and I was getting the build success.

I haven't added the jar file manually. also I was checking the resolution in Github and got this:

https://github.com/Adobe-Consulting-Services/lazybones-aem-templates/issues/8

 

~ Prince

Avatar

Level 2

Hi,

I managed to get the code to build with 

main

<dependency>
                <groupId>com.adobe.aem</groupId>
                <artifactId>uber-jar</artifactId>
                <version>6.2.0-SP1</version>
                <!-- classifier>nonobfuscated-apis</classifier -->
                <scope>provided</scope>
            </dependency>

core

<dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>uber-jar</artifactId>
            <version>6.2.0-SP1</version>
            <classifier>apis</classifier>
            <scope>provided</scope>
        </dependency>

ui

no 6.2 dependency

After that I installed our main bundle successfully. Then I installed our main package but after installing the package, the file structure that starts with / doesn't appear. Only the / appears. In our production application this structure is something like :

/

  apps

  bin

  content

  etc

In the log file I see the exception "24.02.2017 10:35:06.517 *ERROR* [10.5.2.97 [1487925306517] GET /crx/packmgr/installstatus.jsp HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl ServletResolver service missing, cannot ser
vice requests , sending status 503"

Is this the reason the application structure is not created after installing main package?

Avatar

Level 2

I have this in my POM files:

Parent

<dependency>
                <groupId>com.adobe.aem</groupId>
                <artifactId>uber-jar</artifactId>
                <version>6.2.0</version>
                <classifier>obfuscated-apis</classifier>
                <scope>provided</scope>

</dependency>

Core

<dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>uber-jar</artifactId>
            <classifier>obfuscated-apis</classifier>
        </dependency>

UI

<dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>uber-jar</artifactId>
            <classifier>obfuscated-apis</classifier>
        </dependency>