Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

YouTube Embed content not scaling properly...

TommyDAQ-Bates
Level 6
Level 6

I'm really not sure what's going on with this. I've done this many times before, so I'm thinking this may be related to the latest build...

I'm using a YouTube embed tag as HTML content on a custom page to play streaming video within an article. We're designing for iPhone 4, so the source ID file is 649 x 960.

Being that it's a portrait phone app, I've got the embed tag set up in the center of the screen at 640x360. However, when the video loads, it looks like it is scaled at twice the size! The upper left quadrant of the YouTube red play icon is down in the lower right corner of my HTML content area. If I hit play - it even plays it that way, unless I rotate my screen and allow it to play fullscreen, landscape.

I've got about 15 videos in my ExxonMobil app that I had done this exact same way and they work flawlessly. I've even tried copying one from the EM app and pasting it into the current app I'm developing, but to no avail. It has the same scaling problem.

Can you please look into this and see if it's a bug?

Thank you,

Tommy

1 Accepted Solution
TommyDAQ-Bates
Correct answer by
Level 6
Level 6

Thanks Nathan and Christophe... My standard method of using Object > Embed HTML content, and pasting an Embed Tag w/ custom dimensions would generate the right frame, but was incorrectly scaling the content.  The second method listed in the thread Christophe suggested worked properly:

View solution in original post

3 Replies
NMarroquin
Employee
Employee

Hi Tommy, I'm not sure what's going on here. I've forwarded your post to the dev team.

Christophe_Joss
Employee
Employee

Hi Tommy,

can you take a look at the 2 methods listed in this thread: Youtube video not scalling properly on android

These should work for iOS  as well.

Let us know.

TommyDAQ-Bates
Correct answer by
Level 6
Level 6

Thanks Nathan and Christophe... My standard method of using Object > Embed HTML content, and pasting an Embed Tag w/ custom dimensions would generate the right frame, but was incorrectly scaling the content.  The second method listed in the thread Christophe suggested worked properly:

View solution in original post