Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Tablet layout on Android phone (AEM)

Avatar

Avatar
Boost 1
Level 1
tainal33613492
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
tainal33613492
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
tainal33613492
Level 1

26-04-2016

Hi.

We have two separate applications for phone and tablet (after the layout template update only one would be fine). For the newest issue we have only one collection but two different layouts. So the card images are the same but tablet and phone layouts have different font sizes and some different text fields on the cards. Now everything is fine on other devices but Android phone shows the tablet layout. The older issues are still correct also on Android phone. I have tested the app with Samsung Galaxy S5 and Honor. How should this be fixed?

We are going to publish the next issue tomorrow, so I made now a quick compromise and attached the texts to card images.

- taina

iphone_samsung.jpg

Replies

Avatar

Avatar
Boost 5
Level 4
Colin_Fleming
Level 4

Likes

37 likes

Total Posts

160 posts

Correct Reply

35 solutions
Top badges earned
Boost 5
Boost 3
Boost 25
Boost 10
Boost 1
View profile

Avatar
Boost 5
Level 4
Colin_Fleming
Level 4

Likes

37 likes

Total Posts

160 posts

Correct Reply

35 solutions
Top badges earned
Boost 5
Boost 3
Boost 25
Boost 10
Boost 1
View profile
Colin_Fleming
Level 4

26-04-2016

Taina -- thanks for splitting this question off.

I did a really quick test with my iPhone 5S and a Motorola that has dimensions that match the Galaxy S5 -- they both see my phone layout rendition -- I think that's what you expect.

So you have two apps in one project -- cool, they both see the same content.

-- The card images will be the same since all content is the same.

-- May I assume you have one top-level?

-- -- If you have two-top level and different phone and tablet collection structures this would allow different layouts for the different collections...

One new collection, it uses a layout that has both phone and tablet renditions.

-- But this collection is acting differently than previous collections.

-- -- Do the old and new collections all use the same layout template?

If you're interested, I'm willing to take a look at things. If you add me to your project and only grant permission to "View Layouts and Card" I should be able to inspect things and preview the project in AEM Mobile. I'll take a look and share anything I see there. My AdobeID is fleming@adobe.com --

Colin

Avatar

Avatar
Boost 1
Level 1
tainal33613492
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
tainal33613492
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
tainal33613492
Level 1

27-04-2016

Hi. We have two separate apps and top level collections for phone and tablet. In earlier issues we had double versions of all the collections, now lower collections are common to phone and tablet. Every issue has own layouts, earlier separate for phone and tablet, now separate renditions in the same layout. We published the newest issue today, I solved the problem by attaching texts to collection images. But I made a test collection (not published) for you to the bottom of the main collection, I think it explains the problem better than my essay. We have added you to our project, great if you have time to look at it.

Thank you!

- taina

iphone_samsung.jpg

Avatar

Avatar
Boost 5
Level 4
Colin_Fleming
Level 4

Likes

37 likes

Total Posts

160 posts

Correct Reply

35 solutions
Top badges earned
Boost 5
Boost 3
Boost 25
Boost 10
Boost 1
View profile

Avatar
Boost 5
Level 4
Colin_Fleming
Level 4

Likes

37 likes

Total Posts

160 posts

Correct Reply

35 solutions
Top badges earned
Boost 5
Boost 3
Boost 25
Boost 10
Boost 1
View profile
Colin_Fleming
Level 4

27-04-2016

Hey Taina;

I have engineering looking into this. They're trying to find an S5 to test with, we tried a S6 and it received the phone rendition. I'll let you know what I find out.

BTW, your technique of adding a collection and using different card designs calling different metadata is quite clever. Nice technique.

Avatar

Avatar
Boost 1
Level 1
tainal33613492
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
tainal33613492
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
View profile
tainal33613492
Level 1

28-04-2016

Thanks!

I have one more Android test phone with the same result:  HTC One (M8), Android 6.0

It takes the right application, because the earlier issues are correct, maybe the difficulty is with one layout but two renditions?

Avatar

Avatar
Boost 5
Level 4
Colin_Fleming
Level 4

Likes

37 likes

Total Posts

160 posts

Correct Reply

35 solutions
Top badges earned
Boost 5
Boost 3
Boost 25
Boost 10
Boost 1
View profile

Avatar
Boost 5
Level 4
Colin_Fleming
Level 4

Likes

37 likes

Total Posts

160 posts

Correct Reply

35 solutions
Top badges earned
Boost 5
Boost 3
Boost 25
Boost 10
Boost 1
View profile
Colin_Fleming
Level 4

29-04-2016

Hey Taina;

I've shared your info with @Kirk Mattson https://forums.adobe.com/people/kirk%20mattson -- He's looking into this from an engineering perspective while I go on vacation.

Avatar

Avatar
Level 1
peterw5803690
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
peterw5803690
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
View profile
peterw5803690
Level 1

30-06-2016

Hi Colin,

I am having the same issue but across all mobile devices. I have preflighted and the app works perfectly on phone and Ipad. I published and the mobile displays the ipad version. Or if I make the phone the default the Ipad displays the phone version. The app is not recognizing the device. Do you know why this would be? I have created layouts for tablet and phone and the preflight testing is perfect. I'm assuming its an easy fix and I've missed a step here...

Avatar

Avatar
Boost 50
Employee
Bob_Bringhurst_
Employee

Likes

88 likes

Total Posts

411 posts

Correct Reply

113 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile

Avatar
Boost 50
Employee
Bob_Bringhurst_
Employee

Likes

88 likes

Total Posts

411 posts

Correct Reply

113 solutions
Top badges earned
Boost 50
Boost 5
Boost 3
Boost 25
Boost 10
View profile
Bob_Bringhurst_
Employee

30-06-2016

Hi Peter - It's strange that your content is displaying properly in the preflight app but not in the published app. Have you published your layout? It would be great if you could show some screen shots to give us a better idea of what's going on.

Avatar

Avatar
Level 1
peterw5803690
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
peterw5803690
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
View profile
peterw5803690
Level 1

04-07-2016

Hi Bob, thanks for the reply.

I have a feeling that because our app was created and sent to the app stores late last year, before we switched to AEM, that the app version may have to be updated? That would explain why it's working in preflight and then not in the actual app correct?

Avatar

Avatar
Give Back 10
Employee
Christophe_Joss
Employee

Likes

56 likes

Total Posts

241 posts

Correct Reply

67 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Publish 1
View profile

Avatar
Give Back 10
Employee
Christophe_Joss
Employee

Likes

56 likes

Total Posts

241 posts

Correct Reply

67 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Publish 1
View profile
Christophe_Joss
Employee

05-07-2016

Hi Peter,

if you mean that the viewer available on the App Store is still a DPS Classic one that has not yet been updated to an AEM Mobile version then yes you are correct, that would be the cause of this behaviour. DPS Classic and AEM Mobile use different services so what's on the distribution server on the AEM Mobile side would simply not be pushed to  a DPS Classic app.

You'll now need to create an App in AEM Mobile making sure you use the same bundle ID and signing certificates so you can then submit it to the App Store as an update of your existing App.

Hope it makes sense.